2

I know many similar posts have been made in the past and I have gone through all of them. But, I was not able to find anything useful, because most of them says to update the config.txt and the NOOBS version mentioned in them are like below 1.5. So that is why I created a new post.

I just got my RPi2 today and as the part of setting it up I downloaded the latest version of NOOBS (1.7.0). I used the SD formatter tool to format and copied all the extracted files into the SD card. Now when I plug in the RPi2, the monitor shows no signal found message and goes back to power saving mode. The RPi2 and the NOOBS is working perfectly fine when I plugged the same HDMI cable to my TV. Can please someone tell me what am I doing wrong when connecting the RPi2 to my monitor?

My monitor is LG IPS LED 24MP76.

1

Have you made sure your monitor is plugged in, and works fine with that HDMI cable? It seems that your monitor is the faulty link. Try testing it with another HDMI compatible device that you are sure works, since from what you have said it seems the Pi output and cable are working.

  • Yes the monitor is plugged and it works fine. I have been using this monitor for a year for my computer. – iamlucifer Feb 14 '16 at 12:45
0

If the Pi is started without a monitor connected, the HDMI output will not be enabled. Have you tried rebooting with the monitor connected?

  • Yes i have tried rebooting with monitor connected. I plug the Pi only after connecting every device. – iamlucifer Feb 14 '16 at 12:47
  • Are there any other cables connected to the monitor that could be confusing it? Could you try with a different cable? What port do you use to connect your computer to the monitor? – hifkanotiks Feb 14 '16 at 13:34
  • No, I too thought that and removed my chromecast from the HDMI port 2. At present I don't have another cable, will get one tomorrow and try that too. – iamlucifer Feb 14 '16 at 13:37
  • @iamlucifer How did the new cable go - is the problem solved? – hifkanotiks Feb 17 '16 at 21:18
  • No, the issue still exists. :( – iamlucifer Feb 20 '16 at 7:05
0

Could be that the weak HDMI signal output by the Pi is not strong enough for it to be picked up by your monitor, while your TV is more sensitive and can read it.

Try using the config_hdmi_boost=7 option in your Raspi boot file to see if this helps.

I have encountered several monitors that do not work with a Raspi but are fine with a PC, and it seems to be down to signal strength.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.