20

Can I use a SD card from another Raspberry Pi (say a Raspberry Pi 2) on another raspberry pi model (say a Raspberry Pi Zero)?

Note I am NOT referring to the same model! I am referring to DIFFERENT models.

2

6 Answers 6

14

I didn't know the answer to the question and while it seemed obvious that there should be no reason why the SD cards couldn't be swapped from one type of Raspberry Pi to another different type, there was the slightest hesitation in my mind with regard to the difference between the two versions of processor used (ARM1176JZF-S in the Zero, Model A, A+, B and B+ vs quad-core ARM Cortex-A7 in the Raspberry Pi 2).

So I loaded an SD card with a recent vanilla version of Jessie and tested it on a Model 2. I then transferred the SD card to a Model A+. Both worked without any indication of trouble (pinging from a wireless USB dongle).

Of course there would be differences if there were extra peripherals plugged into USB ports of the Model 2 that the A+ didn't have, but all things considered it appears to work.

2
  • 2
    Nice, an answer that is factual and tested :) The reason it works is because the kernel contains drivers for the entire range of Pi's. The OS doesn't care what processor or GPU there is, it just cares that the kernel knows how to talk to it. The problem arises when you specifically use or write software for the Pi 2 and then try and run it on a Pi 1. Similar to desktop computers. You can upgrade or downgrade the processor, sometimes even get away with an entire motherboard replacement, and it will still boot (albeit Windows doesnt like that much, mainly because they dont want ppl to do it)
    – Piotr Kula
    Commented Feb 16, 2016 at 21:41
  • Similarly for me. I prepared a card on a 3B, then moved it to a Zero W and it worked faultlessly. A fairly simple setup - headless, static IP address and wifi.
    – Peter bill
    Commented Feb 20, 2020 at 15:22
2

[Currently this answer is obsolete.]

It is "no" if some specific features (especially boot-time ones) are enabled. E.g. https://www.raspberrypi.org/blog/another-new-raspbian-release/ -- for example in that release there is a Pi 2 only openGL driver that can be enabled via raspi-config but:

... be warned that if you enable it on a Pi 2 and then move that SD card into a Pi 1 or Pi Zero, the Pi will not boot.)

3
  • 1
    I did the initial boot on my Pi 2 and then moved it to my Pi Zero, and it works fine. I've moved between B 1s and B 2s many times, and it always works fine, with both Jessie and Raspbian. Please cite your sources for where you found this information. Commented Feb 17, 2016 at 0:41
  • From the link in the post, it reminded if experimental OpenGL driver is enabled, it won't be boot on Pi1 and Pi Zero.
    – koyeung
    Commented Feb 17, 2016 at 4:14
  • ah, that makes sense. You should add that to your answer, because if the OpenGL driven isn't enabled, switching cards between models is fine. Commented Feb 17, 2016 at 4:15
1

It will work but if you're using an old Noobs installation with separate partitions for OSes a more recent model of Raspberry Pi may need files on the first partition updated. This is not the same as running apt-get update && apt-get upgrade or raspi-update run from Raspbian as Raspbian never touches the Noobs partition which is used during boot process.

You will want to download the latest Noobs image and extract *.dtb, *.bin, *.elf and *.img files and overlays/ directory over to the first FAT32 partition on the SD card.

This did the trick for me when I was stuck with undervolt icon and blinking red icon when moving from Pi Zero (Noobs 2017) to 3B+.

1

Confirmed, I took an SD card from a Pi 3, which I had been using for several years, and popped it into a Pi Zero 2 W. The Zero came up without a hitch.

Documentation on the web says this works for Raspian. Your mileage may vary if you are using Noobs or another OS.

2
0

It seems, that any Pi model is compatible with Pi OS, and there are different configuration codes for all pi model that support 64bit mode (if the os is 64bit), even still not released Compute module 5, if it is it. That means that 64 bit raspberry pi os can be used on any 64bit Pi, and the 32bit Raspberry pi os can be used in any model.

New contributor
Tim is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
-1

It doesn't seem possible to take a configured OS from a Pi Zero W and put it into a Pi 3 A+

My Pi Zero W was configured, upgraded, and I'd installed/configured a bunch of other tools I like to use: SPI/I2C/GPIO, netatalk, pygame. When I took this card from the Zero W and put it in the 3 A+, the machine wouldn't boot. I see an IP on the network, but the OS never seems to load properly. Inspecting with a tool like LanScan on the Mac shows the IP, but no name (usually has hostname & Raspberry Pi foundation listed).

I like to make images of fully configured OSs so I don't have to go through the process of install & config each time. Flashing a 32GB card only takes about 4 mins. This has worked great with Pi Zero W to Pi Zero W, but apparently I'm going to have to image for each Pi. BTW: I created this doc on imaging & restoring for my students (Mac users). If it's useful, feel free to share, but if anyone is inclined to check it out & finds something wrong, pls let me know. http://bit.ly/pi-backup Cheers!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.