7

I just downloaded and installed Raspbian Jessie Lite v2016-02-09 on my Raspberry Pi Zero. The DHCPCD process slows boot time by ~40 seconds. I do not plan to connect to the internet using my Pi. How can I disable DHCPCD / networking?

[...] A start job is running for dhcpcd on all interfaces (38sec / 1min 38sec)

I tried setting up a static IP address, but nothing changed.

4

sudo systemctl stop dhcpcd.service should stop dhcpcd.

It is also possible to set Raspbian to not wait for the network on boot (see raspi-config).

  • 1
    raspi-config does not work ! it is /etc/systemd/system/dhcpcd5 that starts dhcpd networking it seems a bug in upgrade – Bob Bedinsky Feb 27 '16 at 19:43
  • 1
    This works, but then the eth0 interface is disabled. Tested on the latest raspbian-jessie-lite. Would appreciate the solution that does not disable the eth0. I suspect there is a bug somewhere in startup scripts? Strangely enough, wlan0 (on raspberry 3) is unaffected. – xmp125a Jun 1 '16 at 18:27
  • @xmp125a If you have a question ask it - not as a comment on an answer. – Milliways Jun 2 '16 at 0:02
  • I have the same problem. sometimes eth0 comes up, sometimes I get this delay waiting for dhcpd, and then eth0 never comes up, and as it is headless I can't get to it. Cheap hack I added ifup eth0 to /etc/rc.local and that forces the issue, but it would be nice to know what's wrong. – stu Jul 4 '16 at 14:23
1

Disabling helped me much better. Even as the service was stopped after reboot my Pi kept performing the job. Hence,

 sudo systemctl disable dhcpcd.service

did the trick for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.