2

I'm trying to load v4l2 modules. Before doing that, I run:

sudo apt-get install v4l2loopback-dkms

but, when I load the module, I get an error:

sudo modprobe v4l2loopback devices=4
modprobe: FATAL: Module v4l2loopback not found.

My OS:

uname -a
Linux raspberrypi 4.1.17+ #838 Tue Feb 9 12:57:10 GMT 2016 armv6l GNU/Linux

I've followed every step of the question Take picam image while motion is running, but it still doesn't work.

2 Answers 2

0

I had a similar problem trying to install v4l2loopback on a Raspberry Pi 4

I was able to fix it by installing the Raspberry Pi Kernal Headers

sudo apt-get install raspberrypi-kernel-headers

My system via uname -a

Linux raspberrypi 6.1.21-v8+ #1642 SMP PREEMPT Mon Apr 3 17:24:16 BST 2023 aarch64 GNU/Linux

-2

https://github.com/umlaeute/v4l2loopback

    git clone https://github.com/umlaeute/v4l2loopback.git
    cd v4l2loopback
    make && sudo make install
1
  • 1
    Some explanation would be nice to see...
    – Darth Vader
    Commented Jun 7, 2017 at 11:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.