3

Good evening,

I am trying to link a digital thermo sensor (MR003-001) to the I2C pins on A+ Pi. enter image description here I have enabled I2C connection in raspi-config, and download I2CdevTools. user is in i2c group, I provided a 3.3V input to the sensor, which can accept between 2.7 and 5.5V. The physical address is 0x48 by default. enter image description here When I am running i2cdetect -y 1, nothing is detected. I am afraid I may have damaged the sensor (which is brand new). I have only seen a few topics about I2C integrity checks, and all of them were with devices which had worked at least once before. I don't really know what to do to make this sensor visible on I2C port, or at least ensure it isn't broken.

Thanks in advance for any kind of help.

  • I can't see anything wrong with your setup per se. The datasheet for that sensor board indicates that it has a max current usage of 0.5mA, which is well within the capabilities of the 3.3V supply rail on the Pi. If you wanted to rule out supply current/voltage problems it shouldn't do any harm to try connecting it to the 5V pin on the GPIO header. – goobering Feb 17 '16 at 17:30
  • 2
    The header pins do not appear to be soldered to the module. They look like they have just been pushed over. – joan Feb 17 '16 at 17:32
  • I know that, but one thing bothering me was the physical address pin A2 A1 A0. In the datasheet it said the default value was 000, yet just in case I linked them to the ground. Nothing was detected before and after that. A strange thing which occurred while I was trying to wire the A[2:0] pins was the leds on the pi were turning off as soon as I linked the Vcc with one of the A pins. If something was damaged, it happened there. – Raphaël Feb 17 '16 at 17:35
  • I haven't soldered anything, but the connection is good, all the wires are on the matching line. Do you think the connection is unreliable without soldering? – Raphaël Feb 17 '16 at 17:36
  • I have already tried the 5V pin, before switching to 3.3V pin because I had heard pi GPIO weren't 5V tolerant. – Raphaël Feb 17 '16 at 18:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.