My brand new Pi 2 does not pick up my Wi-Fi but it sees all the Wi-Fi nearby, i.e. the neighbors.

I am using the official Pi dongle and have tried all 4 USB ports. I have tried to find answers to no avail.

  • 6
    I think your Wifi is 5GHz and RPi only works with 2.4GHz networks... thats why you see only your neightbours.
    – MadAntrax
    Commented Jun 21, 2016 at 9:03
  • Double check your network with tbe free 'fing' app running on any smartphone.
    – fcm
    Commented Feb 6, 2022 at 12:45

3 Answers 3


Looks like a router problem and not the dongle's issue:

  • Is SSID broadcasted by your router? It won't show if it's hidden.
  • As OS, are you using Windows IoT or Raspbian? Or have you tried the Wi-Fi dongle with another OS than the one you are using?
  • Make sure to try move the Raspberry Pi near the router.

Recently Raspberry Pi has some security concerns with WiFi Connection; don't know why; but there is always a solution for any problem. First of all type sudo iwlist wlan0 scan in your RPi terminal and look if your router is listed or not. If it is listed then great and you are nearly done with setting up your network. If not, then the problem is with your router itself not the RPi. Suppose it is listed, type sudo nano /etc/wpa_supplicant/wpa_supplicant.conf and go to the bottom of this file and paste


and leave a blank line at the end. Hint you will type both your ssid and psk between the double quotes. Now save the file by pressing Ctrl+X then Y, then finally press Enter. I would recommend that you type the following command to reconfigure your WiFi sudo wpa_cli reconfigure. You can verify that you are connected by executing ifconfig wlan0. If the inet addr field has an address beside it, the Pi has connected to the network. If not, check your password and ESSID are correct, and consider rebooting the RPi. If all the above doesn't work for you. Try checking the official RPi website for Setting WiFi Up Via the Command Line Inteface.

It would be great to try this solution on a very fresh image.


In addition to the other answers, it's possible that you are using an unsupported WiFi dongle, or more likely, your WiFi dongle does not support your network type.

Check what type of signal you're broadcasting (ac, b, g, n, etc), and then check if that's supported by the dongle.

  • You can add information that it is possible to check network signal type using device that sees preferred network (e.g. laptop or smartphone) and software like InSSIDer
    – Mark
    Commented Aug 23, 2016 at 10:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.