0

I'm in the USA and I've tried connecting my Raspberry Pi 2 to an HDMI monitor with internal speakers, and also to an HDMI equipped big screen TV, But the HDMI Sound will not work. I verified TV's speakers work fine. Also, I verified that the Monitor's speakers work fine.

I have an intel NUC (no legacy video or audio ports) with Kubuntu 14.04 that uses the internal speakers on the HDMI Monitor, and that works fine.

What do I have to configure to get the RPi2's HDMI to transmit sound? I'm guessing that the RPi2 transmit sound using legacy audio by default, and I have to configure a file somewhere to tell it to transmit via the HDMI cable instead.

PS- this RPi2 will not connect to wifi hotspots either, even though it finds them and reports their signal strength, and I know the password and have connected to the wifi with a laptop and desktop (with Kubuntu and Ubuntu). I mention this in case there's a rare hardware failure that could affect both wifi and hdmi audio. Also I mention that I'm in the USA in case Raspbian sets up some British defaults (that I'm completely unaware of) that are incompatible with USA hardware.

EDIT --NEW INFORMATION--

I downloaded and then installed Ubuntu-Mate-15.10.1 onto the Raspberry Pi 2. Both HDMI sound (and wifi adapter) worked perfectly and effortlessly immediately after installation.

I also downloaded and installed the very latest version of Raspbian [ 2016-02-09 ] Both HDMI sound ( and wifi adapter ) continued to fail, as before.

So, this is definitely Not a Hardware problem with my Raspberry Pi 2. It's certainly an issue with Raspbian, the operating system. Since everyone from Britain and Australia seem to have no problem with HDMI sound (or wifi adapters) using Raspbian, I wonder if this could be a regional incompatibility issue or some sort of hardware blockage by region?

1

did you try to configure this file: /boot/config.txt

I modified that with "nano" editor- just uncomment one line, the one that says:

hdmi_drive=2.

Save the file and than reboot.

  • No I haven't tried that, but definitely will. Thanks! I had no idea it needed to be typed in. Maybe one day Rasbian or Debian can add it to the GUI System Settings (with the audio controls) – user12711 Feb 21 '16 at 22:03
  • I used sudo nano to activate the hdmi_drive=2. Unfortunately, there is still no sound through the raspberry pi hdmi – user12711 Feb 27 '16 at 15:33
  • Sorry for answering so late, did you already solve your issue? Regarding configuration problems there is also another option. In terminal window type: sudo raspi-config Then choose "Advanced options". In the next window choose "A9 Audio" Then choose the audio output - nr. 2 "Force HDMI". Now, be sure to save the settings correctly (you can move with "tab button" and confirm with "enter"). Reboot. Hope it helps... – Dunav Rajna Mar 8 '16 at 13:04
  • Raspbian still isn't working with the HDMI audio, even after adding the "hdmi_drive=2" line. Also, none of my USB-wifi adapters work with Raspbian -- even though they can all detect the hotspots and signal strengths, Raspbian simply refuses to do anything with the wifi hotspots beyond showing the available ones and their signal strengths. (I wonder if the problem is related) Interestingly though, Ubuntu-Mate had ZERO problems: HDMI audio automatically worked, and wifi worked, and without any configuration adjustments. Perhaps the Raspbian problem only affects USA. I never hear about it. – user12711 Mar 8 '16 at 21:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.