5

I am trying to connect internet using a USB WiFi Adapter I bought this afternoon. It is a TP-LINK TL-WN725N.

1) - I searched on the internet, and many users are using this adapter. I first installed the needed driver, following this method :

Usb driver by Raspberry Kernel versions

2) - The thing is that the raspberry detects the USB adapter, because it is listed when executing ifconfig command :

wlan0 Link encap:Ethernet  HWaddr 60:e3:27:19:f9:05  
      adr inet6: fe80::817:3e4d:1acb:e06e/64 Scope:Lien
      UP BROADCAST MULTICAST  MTU:1500  Metric:1
      RX packets:0 errors:0 dropped:16 overruns:0 frame:0
      TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 lg file transmission:1000 
      RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

3) - When starting wpa_gui, no adapter is found, and the GUI displays "Could not get status from wpa_supplicant".

I saw that many people had the same issue. I tried many configurations, with the /etc/wpa_supplicant/wpa_supplicant.conf and /etc/network/interfaces.

intefaces :

source-directory /etc/network/interfaces.d

auto lo
auto wlan0

iface lo inet loopback
iface eth0 inet dhcp

allow-hotplug wlan0
iface wlan0 inet manual
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf
iface default inet dhcp

wpa_supplicant.conf :

trl_interface=DIR=/var/run/wpa_suppliment GROUP=netdev
update_config=1

network={
        ssid="ssid"
        proto=RSN
        key_mgmt=WPA-EAP
        pairwise=CCMP
        auth_alg=OPEN
        eap=PEAP
        identity="user"
        password="password"
        phase2="auth=MD5"

}

Finally, the Wifi adapter works, because the iwlist wlan0 scan prints all the WiFi hotspots around me. I tried everything I saw on the internet, but I can't make that WiFi adapter to work.

0

Try putting this in your /etc/network/interfaces file:

auto lo

iface lo inet loopback
iface eth0 inet dhcp

allow-hotplug wlan0
iface wlan0 inet dhcp

wpa-ssid "ssid"
wpa-psk "password"
  • dhcp not manual. You don't have to mess with your wpa_supplicant.conf file. Put it back to default. – 1'' Feb 23 '16 at 6:36
  • Are you aware what the "default" actually is? – Milliways Feb 23 '16 at 7:42
  • The thing is that I don't know how to configure the WPA settings through the interface file, because as you can see on the snippet I have posted, the WiFi hotspot i'm dealing with requires complex authentication. And, at the beginning, my wpa_supplicant.conf file was empty. I added the two lines after reading a tutorial. – Scaraux Feb 23 '16 at 12:18
  • And also, I would like - if possible - to use wpa_gui. – Scaraux Feb 23 '16 at 12:46
0

Ok, I decided to reinstall Raspbian, with the USB WiFi adapter plugged-in. Now everything works, I did not have to configure anything.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.