3

I have had a hard time with this Pi, finding the drivers was not a easy task, and now am experiencing a new issue.

My WiFi dongle is flashing green (which is a good sign). In the GUI WiFi setup it's saying I am connected, but problem is I don't have a IP address nor am I able to ping or connect to the internet.

Interfaces File

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1

network={
        ssid="Claro"
        psk="password12"
        proto=RSN
        key_mgmt=WPA-PSK
        group=CCMP TKIP
}

GNU nano 2.2.6 File: /etc/network/interfaces

auto lo
iface lo inet loopback

auto wlan0
allow-hotplug wlan0
iface wlan0 inet manual
wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf

I am running Raspbian Wheezy.

  • Depending on the OS release the above won't work (unless you have made other changes). See raspberrypi.stackexchange.com/a/37921/8697 I haven't the faintest idea what "its saying i am connected in the GUI wifi setup only problem is I don't have a IP address" actually means. – Milliways Feb 23 '16 at 1:02
  • so when i open the graphical interface on the desktop and open the wifi set-up I look and it says I am connected , it goes through the handshake etc. and claims i am connected to my network, but when i try to go to google for an example it will not work and unable to obtain IP, I will check the link out, thanks – TravJav92 Feb 23 '16 at 1:19
  • unfortunately this did nothing... took me back to my starting point essentially. restored it to my last settings as it seemed to be progress in comparison of sitting doing nothing...Really wish there was a official page dedicated to this stuff – TravJav92 Feb 23 '16 at 2:37
  • what does ifconfig show? There are official pages, but they all assume you are using the latest version and not using out of date configuration files. Is this a new installation? Why are you trying to use Wheezy - which is not supported, or even available any more? – Milliways Feb 23 '16 at 2:40
  • pi@raspberrypi ~ $ uname -a Linux raspberrypi 3.18.7+ #755 PREEMPT Thu Feb 12 17:14:31 GMT 2015 armv6l GNU/Linux pi@raspberrypi ~ $ ifconfig wlan0 Link encap:Ethernet HWaddr 30:b5:c2:05:ff:16 UP BROADCAST MULTICAST MTU:1500 Metric:1 RX packets:0 errors:0 dropped:0 overruns:0 frame:0 TX packets:0 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000 RX bytes:0 (0.0 B) TX bytes:0 (0.0 B) pi@raspberrypi ~ $ – TravJav92 Feb 23 '16 at 2:52
1

Try putting this in your /etc/network/interfaces file:

auto lo

iface lo inet loopback
iface eth0 inet dhcp

allow-hotplug wlan0
iface wlan0 inet dhcp

wpa-ssid "Claro"
wpa-psk "password12"
  • If you get an error, change your wpa_supplicant.conf back to default. – 1'' Feb 23 '16 at 6:37
  • I have had issues with wheezy and wifi in the past, jessie fixed this for me. wpa supplicant didn't do the trick for me, sot his answer might be useful to try out. – Havnar Feb 23 '16 at 12:24
  • Hey guys, I actually changes the OS over to Jessie and it works great just very slow when accessing the terminal unfortunately but may be voltage issues – TravJav92 Feb 23 '16 at 16:56
0

Changed to Jessie worked out of the box. Had issue with voltage because my usb port was hogging energy, as well as using a host-dependendent USB hub.. solution was to use independent USB hub or just use SSH, works amazing.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.