2

I have a small python script that uses Requests and simply does a GET request from an api to pull data. This script works fine on my computer and fine on a pi A, but not on the actual Pi B that I'm trying use it with.

Basically the script fails to execute the GET request on some URLS, not all, just some....using tail -f /var/log/syslog I can see that this keeps happening:

Feb 22 17:57:55 raspberrypi dhcpcd[445]: eth0: fe80::3e7a:8aff:fe59:68d6 is unreachable, expiring it
Feb 22 17:58:12 raspberrypi dhcpcd[445]: eth0: fe80::3e7a:8aff:fe59:68d6 is unreachable, expiring it
Feb 22 17:58:44 raspberrypi dhcpcd[445]: eth0: fe80::3e7a:8aff:fe59:68d6 is unreachable, expiring it
Feb 22 17:59:01 raspberrypi dhcpcd[445]: eth0: fe80::3e7a:8aff:fe59:68d6 is unreachable, expiring it
Feb 22 17:59:16 raspberrypi dhcpcd[445]: eth0: fe80::3e7a:8aff:fe59:68d6 is unreachable, expiring it
Feb 22 17:59:32 raspberrypi dhcpcd[445]: eth0: fe80::3e7a:8aff:fe59:68d6 is unreachable, expiring it
Feb 22 18:33:12 raspberrypi rsyslogd-2007: action 'action 17' suspended, next retry is Mon Feb 22 18:34:42 2016 [try http://www.rsyslog.com/e/2007 ]

my ifconfig settings:

eth0      Link encap:Ethernet  HWaddr bb:bb:bb:bb:bb:bb  
          inet addr:10.0.0.21  Bcast:10.0.0.255  Mask:255.255.255.0
          inet6 addr: bbbb::bbbb:bbbb:bbbb:bbbb/64 Scope:Link
          inet6 addr: bbbb:bbb:bbbb:bbbb:bbbb:bbbb:bbbb:bbbb/64     Scope:Global
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:13803 errors:0 dropped:0 overruns:0 frame:0
          TX packets:11236 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:2410136 (2.2 MiB)  TX bytes:4368966 (4.1 MiB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:47 errors:0 dropped:0 overruns:0 frame:0
          TX packets:47 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:6156 (6.0 KiB)  TX bytes:6156 (6.0 KiB)

Here is my /etc/network/interfaces:

# interfaces(5) file used by ifup(8) and ifdown(8)

# Please note that this file is written to be used with dhcpcd
# For static IP, consult /etc/dhcpcd.conf and 'man dhcpcd.conf'

# Include files from /etc/network/interfaces.d:
source-directory /etc/network/interfaces.d

auto lo eth0
iface lo inet loopback
iface eth0 inet static
address 10.0.0.21
netmask 255.255.255.0
gateway 10.0.0.1

I took off real mac address and ipv6 addresses (yes the 2nd eth0 IPV6address looks malformed, but that's what it looked like on my settings)

Also, its not that nothing works - its that certain GET requests don't work...any ideas???

1

If you are using dhcpcd, which is the default for newer Raspbian, setting static like this doesn't work. (Actually it may, but this won't shop dhcpcd from trying to allocate too). See https://raspberrypi.stackexchange.com/a/37921/8697 for a tutorial.

Are you actually trying to use ipv6?

PS There is no need to be coy about the link-local address. This is not routable. Mine is inet6 addr: fe80::3e93:18ca:78ee:7e46/64 Scope:Link

  • I COMPLETELY forgot about this question - turns out the issue was related to an issue related to my client's ISP. – Frankenmint Jul 25 '16 at 8:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.