2

I’m trying to get a wifi hotspot set up on the Pi and am using the Broadcom Wi-Fi Adapter with USB hub. I'm not sure what driver to put in hostapd.conf file, any help would be great. This is what I have in there at the moment:

interface=wlan0
*driver=rtl8192*
ssid=PI_ROUTER
hw_mode=g
channel=6
macaddr_acl=0
auth_algs=1
ignore_broadcast_ssid=0
wpa=2
wpa_passphrase=password
wpa_key_mgmt=WPA-PSK
wpa_pairwise=TKIP
rsn_pairwise=CCMP

...and this is the error I get:

sudo /usr/sbin/hostapd /etc/hostapd/hostapd.conf

Configuration file: /etc/hostapd/hostapd.conf
Line 2: invalid/unknown driver 'rtl8192  '
1 errors found in configuration file '/etc/hostapd/hostapd.conf'
  • daveconroy.com/… is a similar module to what you have and could be of help. – BantuTech Feb 24 '16 at 15:31
  • run lsusb with the adapter plugged in. Sometimes manufacturers change chipsets and don't tell anybody. :) – tlhIngan Jun 4 '16 at 23:24
1

Try to use the driver nl80211. If that doesn't work, remove or comment out the line altogether.

1

Firstly, you need to check the drivers supported by Linux. This is the website you can find more information: https://wireless.wiki.kernel.org/en/users/drivers.

Where as rtl8192ce has a support, its possible to configure at hostapd conf.

You need to set up with correct name of driver, something like this.

{code} driver=rtl8192ce {code}

If this didn't solve the problem then install sudo apt-get install libssl-dev it will solve it.

1

If you are using wheezey checkout the instructions at coderbot.org or simplesi.net i have used them in the past and managed to create a hotspot.

I am struggling to create a hotspot using jessie.

1

If all the other advice fails, try Ubuntu-Mate. I had 4 usb wifi adapters, two of which were advertised to have worked with my Raspberry Pi 2. Although all 4 adapters found my wifi hotspot, none would even attempt to connect to any of the strong hotspots it found. That was using the latest Rasbarian (Debian-Jessie).

Then I created another micro-sd bootup card, with Ubuntu-Mate. On the First Boot, I clicked my wifi-hotspot, plugged in the password, and BINGO -- IT WORKED!! And, my HDMI-sound also instantly worked, whereas before hand I couldn't get that to work either. I don't know if any of the troubles had to do with me being in the USA, and perhaps Raspbarian not does not work well for unknown reasons. But Ubuntu-Mate had ZERO Problems.

I'm guessing all the Raspberry Pies have enough power to boot Ubuntu-Mate, connect to WiFi from the desktop, and run the terminal shell -- BASH

  • 1
    Thanks for the feed back ill give it ago as soon as i can. sorry for the well over due response go distracted by other projects – user3149912 Apr 26 '16 at 12:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.