3

I'm having exactly the same issue than here:

When I'm in Visual Studio, and I try to deploy I got some error messages:

1>Error: Unable to connect to the Microsoft Visual Studio Remote Debugger named '192.168.0.25'.  The Visual Studio 2015 Remote Debugger (MSVSMON.EXE) does not appear to be running on the remote computer. This may be because a firewall is preventing communication to the remote computer. Please see Help for assistance on configuring remote debugging.

(obviously, I did make sure that I don't have any firewall).

If I go on http://192.168.0.25:8080 which is my Raspbery Pi, I get the win 10 dashboard.

In this dashboard, if I try to click on Debug->Start Visual Studio Remote Debugger -> Start, it says:

Failed to start the Visual Studio Remote Debugger. Make sure the remote debugger is copied to the device using Visual Studio
For more information please visit www.windowsondevices.com

I just created a blank dummy project, so I don't think it's coming from the content of the project.

They solved the issue by setting the authentification mode to "Universal", but I don't have this option, in fact when I initially selected the device, I only had Windows or None. And if I got to the settings now, I've only a checkbox: enter image description here

I'm not sure what I did wrong, what I don't have this option, any idea?

  • Did you find the remote machine using the Pi tool thing? – Piotr Kula Feb 24 '16 at 19:06
  • 1
    Yes exactly. In fact I found that Visual Studio doesn't want to upgrade to the latest version for the 51886 build, which maybe contains this new field – J4N Feb 25 '16 at 5:58
0

I had this same problem when trying to debug an application against the Insider Preview, build 10.0.14295.0.

To solve this error I connected to the a Rasberry Pi RTM version of Windows IoT using windows explorer, and found the dev tools located at the following folder. I was then able to copy this folder to the Insider Preview Build of Windows 10 IoT, and remote debugging and deploy worked.

The remote debugger files were located at:
\\<IP ADDRESS>\u$\Users\DefaultAccount\AppData\Local\DevelopmentFiles
0
  1. I can see that the project screenshot has x86, project platform must be set as ARM

  2. Install VS2015 update 3 with see attached image

visual studio screen shot

Best of luck

0

I found a solution in this thread: https://stackoverflow.com/a/37298978/4473230

The first time you attempt Remote Debugging, VS will copy the remote debugger files to u$\Users\DefaultAccount\AppData\Local\DevelopmentFiles automatically!

0

I had a similar error on VS 2017 that looked like this:

DEP6720: Failed to deploy package 'Native Debugger' (EB22551A-7F66-465F-B53F-E5ABA0C0574E). 
DEP6950: Error transferring the file to the remote device: 'C:\Program Files (x86)\Microsoft Visual Studio\2017\Enterprise\CoreCon\Binaries\Phone Tools\Debugger\target\armv4i\msvcp140.dll. The system cannot find the file specified. (Exception from HRESULT: 0x80070002)'.

I was able to solve manually creating a release package of the app (right click project->store->create app package). Then I connected to the IoT portal and deployed the app manually selecting all the dependencies.

Since then, the debug started working.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.