1

I recently had to reformat my sd card for my pi as I was getting an error (below), no idea what had caused this error but reformatting fixed it.

kernel panic not syncing: VFS: Unable to mount root fs on unknown-block 179,6

Now I am having a new issue when booting, probably around 50% of the time. When booting it sometimes hangs on:

waiting for /dev to fully populate

Or words to that effect. Following this it seems to cycle, very quickly, through some code that keeps throwing up errors and never boots. The only way I can fix it is by pulling the plug (I know, bad practice, but I can't get it to stop any other way).

Any ideas what could be causing this and how I can stop it?

FYI. I am using a mobile phone charger to power the pi and always have, never had this issue prior to formatting the sd card.

  • Try re-reformatting the card..? – Patrick Cook Feb 24 '16 at 22:04
  • 1
    The 1st error indicated a corrupted SD Card. The 2nd is unusual, and could be caused by many things, but is not good. Despite many horror stories SD Cards are not that delicate. The experienced users on this site rarely have problems. You should use a good quality brand name card. I wouldn't rule out the charger. Many recent smart phones have chargers which meet the new USB spec, but allow voltage to fall as low as 3.6V. Any charger which claims to supply more than 1A probably falls into this class. You should use a proper power source. – Milliways Feb 24 '16 at 22:57
  • As Milliways told you, my guess would be that your sdcard is just corrupted or at least has some trouble. Regarding what you're doing with your SD Card you should avoid writing too much on it, for instance be careful with operation such as copying or saving multiple time with cron jobs or having custom programs writing continuously on the sd it may corrupt the sd more quickly than you'd expect (if it's not a high quality one). – YCN- Sep 24 at 14:30
0

waiting for /dev to fully populate is a symptom usually caused by a faulty/bad accessory (usually a USB device) or a bad/corrupt driver of said device. This error is usually associated with wireless adapters and their community-compiled, possibly buggy drivers but it could be any device, not just WiFi adapters. Pull out all your USB devices and check to see if it's still there.

As for kernel panic not syncing: VFS: Unable to mount root fs on unknown-block 179,6, it means something is wrong with the block device it's trying to mount on. This shouldn't really happen except when the system is somewhat corrupted.

Given faulty hardware and corrupt system files, I conclude that your SD card is at fault. Go try out another one, preferably name-branded as Milliways has suggested. Also, using a known good power supply shouldn't hurt, again as stated by Milliways in his comment.

If the error doesn't show up anymore, start plugging in your USB devices one by one, if any. Reboot after each added device and check for errors.

If there's no error after doing that, my assumptions are correct and the SD card is at fault. If a USB device caused it, I'm still right (read paragraph 1).

If all else fails, read this answer to get some tips on how to get a replacement Pi for free.

  • Thanks for such a detailed response. I only have a wifi adapter plugged into the usb ports, one I bought from modmypi, recommended for the raspberry pi. I remote into my pi so the wifi adapter is essential. I will try removing it and booting. As I type this it has happened again so I will have a go - Removing the wifi adapter has resulted in the pi booting properly. I will reboot another 10 times or so to check it wasn't fluke. As for the SD (samsung evo 16gb), I bought it from, modmypi, preloaded with NOOBS. I may replace it and see how I get on. Thanks again!! – Robin Feb 25 '16 at 17:58
  • If it is indeed the wifi adapter and a driver related issue is it possible to repair this? or better to just replace? – Robin Feb 25 '16 at 17:59
  • 3 out of 4 boots failed with the wifi removed (I have some python script that starts on boot and it gives me a brief beep to let me know it has booted OK - i.e there is nothing attached to USB/HDMI. I do still have some other kit attached to the GPIO pins. – Robin Feb 25 '16 at 18:07
  • @Robin Have you tried with a different SD card yet? There's a small but real chance of it being broken even if it's name-branded. – Gene Dela Rosa Feb 26 '16 at 1:54
  • Not yet, I don't have a spare but have ordered one. I will let you know once I've tried it. – Robin Feb 26 '16 at 8:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.