0

The primary problem I am having is that I do not get audio via HDMI at boot. I had gone through the various steps outlined in several places related to modifying /boot/config.txt without any success. It wasn't until my friend loaned me his RPi2 w/ his bootable SD card that I made some headway.

He said he was having a similar problem to mine, in that he had no audio over HDMI from boot, however he could get audio to start working if he launched an emulator from Retropie. In this case an N64. So I started looking at his to see what was different and noticed he had a value set for 4 Default Video Mode for <emulator> in the emulator configuration (press x on launch of emulator).

I did the same with mine and was able to initialize the audio once the emulator launched, in my case I can reproduce this with any emulator so long as it has a default setting. After that I could continue on with audio until I rebooted my device. Any time I reboot, I have to launch an emulator where I have a Default Video Mode set.

My question is this; is there some other place I can make a modification to have this happen on boot instead of having to start an emulator first?

Here are the various things I have set at the moment. I have tried different configurations of these settings during the time I have been trying to get this working properly:

/boot/config.txt

gpu_mem_256=128
gpu_mem_512=256
gpu_mem_1024=256
overscan_scale=1
hdmi_drive=2
config_hdmi_boost=4
hdmi_group=2
hdmi_mode=16
hdmi_force_hotplug=1
#hdmi_force_edid_audio=1

/opt/retropie/configs/all/retroarch.cfg

(Audio section only)

audio_enable = true
audio_volume = 12.0
# audio_mute_enable = false
audio_out_rate = 44100
# audio_resampler =
audio_driver = sdl
#audio_device = hw:0,1
# audio_dsp_plugin =
# audio_filter_dir =
#audio_sync = true
# audio_latency = 64
# audio_rate_control = true
# audio_rate_control_delta = 0.005
# audio_max_timing_skew = 0.05

/opt/retropie/configs/all/videomodes.cfg

lr-mupen64plus="DMT-17"
lr-snes9x-next="DMT-16"
  • Poking through their github I can see a couple of places where HDMI type settings are applied. Have you tried amixer cset numid=3 2? Explanation here. – goobering Feb 25 '16 at 17:13
  • Yes, I have tried that already. All of the config settings, from what I can tell are correct, it's just that the audio does not initialize. Something is happening when the emulator starts up that actually initializes the audio output via HDMI. Do you know of any place that includes /opt/retropie/configs/all/videomodes.cfg? that is where the selected video mode gets stored for the emulator. And once that is read, the audio is initialized. Perhaps I can track down what is happening if I can step through the initialization flow. – gmiley Feb 25 '16 at 17:17
  • Are you using Mupen64? – goobering Feb 25 '16 at 17:47
  • Yes, for the n64, however this seems to be emulator-agnostic as I can replicate the solution using snes9x-next as well. I just need to set a default video mode for whichever emulator I am using. – gmiley Feb 25 '16 at 17:50
  • videomodes.cfg should be on your Pi - try sudo nano /opt/retropie/configs/all/videomodes.cfg . – goobering Feb 25 '16 at 17:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.