I recently purchased this USB hub for use with my raspberry pi. However I've been having issues with it and my external hard drive.

When I plug the drive in everything appears to be okay. The LED on the Hub lights to inform me that the system has recognized the device, the disk spins up, and the light on the drive itself turns on. However it never shows up in /dev.

When I check the log it appears that it has tried to mount, but always fails with something like "Cannot support over 500mA." My hub should be supplying about 900mA.

  • Is this more likely a hardware or a software problem?
  • Is there any way to force it?

Edit: I think this is a problem with the Hub. The RPi recognizes it, but to no avail. Here's my dmesg output.

  • I can't find any technical specifications for the device. But it seems like it should work to me...
    – Jivings
    Jan 5, 2013 at 19:30
  • A bit more information about the hub here.
    – Jivings
    Jan 5, 2013 at 19:35
  • This looks like the spec of the hard drive (PDF), but it appears to have it's own power supply so I'm confused. More information about the hardware is required for an answer to this question I think.
    – Jivings
    Jan 5, 2013 at 19:44
  • Yes, it did come with a USB power cable... Unfortunately I'm not sure where I lost it. It's been fine running off USB power from my Late 2009 21.5" iMac.
    – Sparky
    Jan 5, 2013 at 20:34
  • I would expect that could be the problem. It appears the hub cannot power the hard drive. Do you have anything else plugged into it?
    – Jivings
    Jan 6, 2013 at 9:58

5 Answers 5


Y-cables are cables which plug into two USB ports to double the available amperage (generally providing up to 1 amp of power, 0.5 amp from each port). These cables will not work on a Raspberry Pi due to the fact that the R.Pi uses the same 0.5 amp power for both USB ports.

If a single port did not work, then drawing power off both ports won't work either. You will need a 1-amp powered USB hub (not a 0.5 amp powered USB hub as many are), or better yet, a powered external drive.

Note that you might be able to connect a Y-cable to both the hub and the Pi. That might work, as each will supply 0.5 amp of current. Let us know if this works!


you need to make sure you put the power to the usb ports. See my comments from my Pi2 with direct attached a WD 1TB paspoort drive.

# Raspberry PI 2
# More power to the usb ports
# You need a 2A power supply
# ===========================

sudo nano /boot/config.txt
sudo reboot
  • This question pre-dates the Pi 2, and involves a powered hub, but your answer may be useful to posterity.
    – goldilocks
    Dec 15, 2015 at 4:44
  • [Thank you for removing the superflous commands.]
    – goldilocks
    Dec 15, 2015 at 10:09

I got a USB hub with 5V 0.5A power adapter, and it didn't work for my portable hard drive.

So i got an old D-Link router adapter with 5V 1.2A instead to make it work.

Also i tried a y cable but it didn't work when i plugged both heads in the RaspberyPi i had to use external USB phone charger.

so if you have a powered hub with more than 0.5A it could work else try changing the power supply.


I had a similar problem with an external HDD in a USB enclosure. The USB spec is .5A, but some drives, like mine and possibly yours, need more to spin up. Most modern desktop and laptop computers supply more, so I had never had a problem before.

One solution I am trying is a Y cable, once it arrives, so I can hopefully get more power to the USB drive. This may work… [Update - it did work when I plugged it into the external USB hub!]

Another is an enclosure with its own power supply.

With a 4A converter, you'd expect that USB hub to be able to deliver a little more, but it may cap the power at .5A for each.


I think my USB hub is cheaper than your Plugable 7 Port, but it can handle 5vDC 2A properly. Maybe your hub is not broken, but the internal circuit equipped with current limiter for safety purposes?

You can try to add an external power source to the hub. This is my cheap (USD 2.40), modified USB hub -




Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.