There seems to be a (very small) time winodw when my pi will let me ssh to it. I got my computer to accept the new key and prompt for my password once (so it did connect), but I had forgotten to specify the user and I couldn't log in. Furthermore, the pi usually doesn't respond to ping requests. However, I can see that it has an active IP address on my router. Usually I get the "no route to host" error when I attempt to connect. Is this normal behavior? Do I need a better power supply or is something else wrong?

Note: I'm using the up to date raspbian wheezy image from here but I also tried the arch version and that didn't work either.

UPDATE: I tried hardwiring my laptop and sshing into my pi from my router but both attempts still produced the "No Route to Host" error. All the lights flash on the pi, but they eventually all turn off except for the power LED and sometimes the ACT light. From the router, I can see the pi establish anywhere from 0-5 connections during startup. However, they also end up going away.

UPDATE 2: I added a python script to my pi's /etc/rc.local file that would connect to my computer (which was running python's simple HTTP server) with wget and then ping my router. However, I never recieved any connections on my computer from the pi so I am beginning to suspect that this is a network/router problem. Are there any router settings that should be enabled for the pi?

  • As long as SSH is running it should be available constantly.
    – Jivings
    Jan 5, 2013 at 20:07
  • @Jivings That's the problem. I think it stops running right after boot up.
    – Vreality
    Jan 5, 2013 at 20:10
  • I think this has been reported before, let me look around.
    – Jivings
    Jan 5, 2013 at 20:15
  • What is the output if you try running ssh -vvv localhost on the Pi?
    – Jivings
    Jan 5, 2013 at 20:18
  • 1
    You will have to put a monitor on it. An analog TV should work fine with a SCART to RCA phono adapter. Then at least you can see it boot. I suspect you have a bad image on the SD card.
    – Julian
    Jan 5, 2013 at 20:25

1 Answer 1


For some reason, I had to reinstall raspbian for this to work (I believe that the SD Card's partition had become corrupt from repeated loss of power as I was testing the pi).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.