7

I want to install Mysql 5.7 on Raspberry Pi 2 with Raspbian Jessie. When I execute the command apt-get install mysql-server, it installs version 5.5.

What do I need to do?

Update

I did every step in @Sapher answer, but didn't work.

Ign http://mirrordirector.raspbian.org jessie/contrib Translation-en
Ign http://mirrordirector.raspbian.org jessie/main Translation-en_GB
Ign http://mirrordirector.raspbian.org jessie/main Translation-en
Ign http://mirrordirector.raspbian.org jessie/non-free Translation-en_GB
Ign http://mirrordirector.raspbian.org jessie/non-free Translation-en
Ign http://mirrordirector.raspbian.org jessie/rpi Translation-en
Fetched 20.2 kB in 12s (1,596 B/s)
W: Failed to fetch http://repo.mysql.com/apt/debian/dists/jessie/InRelease
Unable to find expected entry 'mysql-apt-config/binary-armhf/Packages' in       
Release file (Wrong sources.list entry or malformed file)

E: Some index files failed to download. They have been ignored, or old ones      
used instead.
root@raspberrypi:~#  apt-get install mysql-server-5.7 -y
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package mysql-server-5.7
E: Couldn't find any package by regex 'mysql-server-5.7'
root@raspberrypi:~#
4
  • 3
    You will likely need to compile from source to get the bleeding edge. – Steve Robillard Feb 29 '16 at 11:55
  • maybe can test teh command: sudo apt-get install mysql-community-server_5.7 -y – user46780 May 19 '16 at 14:34
  • @SteveRobillard: or use Arch – Jacobm001 May 19 '16 at 16:40
  • My Bad, I'm sorry. I did delete that wrong answer – severin.julien May 20 '16 at 4:45
1

Raspbian Jesse is a Debian flavor of Linux, which takes a conservative approach to including new versions in the stable release. The advantage is that the libraries have been thoroughly tested and you're unlikely to have any problems. The disadvantage is you might not always be using the most recent release.

There are "testing" and "unstable" versions of Jesse that haven't been fully tested, but even "unstable" version of MySQL is 5.6. So, if you really need MySQL version 5.7, you'll have to download the source and compile it from scratch.

If the source depends on packages that you don't have in the stable release, and you must get them from "testing" or "unstable", it opens a can of worms as your version becomes a mixture of tested and untested packages that might or might not work with the rest of your applications.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.