I'm new on the forum and on Raspberry too... I'm trying to install Bluez 5.37 on my Raspberry because I need to power on a Sitecom Bluetooth USB dongle. This dongle need this version to go in HCI mode, the version with apt-get doesn't have the csr2 mode.

So I started with the installation from source but when I provide the make command the following error is returned:

src/plugin.c: In function ‘plugin_init’:
src/plugin.c:139:14: error: ‘__bluetooth_builtin’ undeclared (first use in this function)
for (i = 0; __bluetooth_builtin[i]; i++) {
src/plugin.c:139:14: note: each undeclared identifier is reported only once for each function it appears in
Makefile:8106: recipe for target 'src/bluetoothd-plugin.o' failed
make[1]: *** [src/bluetoothd-plugin.o] Error 1
Makefile:9157: recipe for target 'check' failed
make: *** [check] Error 2

Previously, the ./configure command goes well.

Someone can help me?


Might be genbuiltin permission problem.

I tried to give src/genbuiltin and obexd/src/genbuiltin -x (execute) permission, and it worked.


I had the same problem and I installed alsa which then solved the problem.

  • 2
    alsa? How does that help? Can you edit your answer and provide a command line, or GUI, method for installing the package? – Greenonline Apr 20 '16 at 6:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.