0

As the title says I'm having problems with CUPS on my RPi when printing things to paper.

The way I have tried is by running lp /home/pi/Desktop/python/car.py with the default printer already set.

When i run that however i get this: request id is UglyBrother-11 (1 file(s)) and nothing prints.

What is very interesting is if i try sudo lp /home/pi/Desktop/python/car.py I get the error:

lp: Error - no default destination available.

I know that this is a valid filename and I can otherwise edit, view and run it.

I've tried a pi zero, Two and Three all running the latest version of Raspbian with CUPS installed (sudo apt-get install cups) and none have worked.

| improve this question | | | | |
  • Please add more information, your Pi model, Wheezy or Jeesie (or other), the program you're using to print, anything that you think it could be usefull to describe your problem. – Elber CM Mar 1 '16 at 21:15
  • To start, I don't think you have a printer connected physically to your RPi, then you will need to install CUSP (Common Unix Printing System) and define/connect your external 'remote' printer (via TCP/IP). – fcm Mar 2 '16 at 14:06
  • OK where can i download it? or what command ro run? – sir_ian Mar 2 '16 at 19:01
  • what kind of printer do you have? can it print the CUPS test page? – scruss Feb 10 '17 at 13:26
  • @scruss this problem has been fixed, I'm trying to find the tutorial I used to post an anwser but I remember it involved adding myself to the lpadmin group. – sir_ian Feb 10 '17 at 23:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.