I want to use an UMTS/GSM - Stick to connect the RasPi with the Internet. I installed the ppp package and configured the provider information as described here (German article). As OS I am using the wheezy-amel-soft-float v3.2.27+.

The UMTS-Stick is a "ZTE Corp." Model "MF110". The command lsusb prints this:

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 0424:9512 Standard Microsystems Corp.
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp.
Bus 001 Device 004: ID 19d2:2000 ZTE WCDMA Technologies MSM MF627/MF628/MF628+/MF636+ HSDPA/HSUPA

When I run sudo pon o2 (o2 is my provider configuration) noting happens and plog prints this:

Jan  6 11:51:27 raspberrypi pppd[2020]: pppd 2.4.5 started by root, uid 0
Jan  6 11:51:27 raspberrypi pppd[2020]: tcgetattr: Inappropriate ioctl for devic                          e (line 940)
Jan  6 11:51:28 raspberrypi pppd[2020]: Exit.

What went wrong and what can I do to solve it?

1 Answer 1


I commented on a similar question, I have had good luck with the Sakis3G script, and this tutorial. One thing to note is that the stick might well require more power than the Pi's USB port can provide, so use a powered hub. This was the case for me, when plugged directly into the Pi the stick was detected OK, but somehow failed to connect to the network. With a powered hub it worked, I posted about my Pi networking here.

Try a powered hub, if that does not work, give Sakis a try, it is very easy to use as all you have to do to connect is answering a few questions.

For more details, please give the model of your stick. Run lsusb, and post the line related to the stick.

  • Sakis3G works very good, i have an internet connection now! The stick is connected to the ras-pi USB port, no hub is needed for my old ZTE MF110 stick. How can I use pon/poff now, is it possibe to derive the script Sakis3G use?
    – Chriss
    Jan 6, 2013 at 15:44
  • > How can I use pon/poff now, is it possibe to derive the script Sakis3G use? It is : sakis3g connect APN="xyz" / disconnect
    – Chriss
    Jan 6, 2013 at 16:35
  • I don't know about pon/poff. However, sakis can be used to connect without any manual menu selection, if you put the information on the command line. Once sakis is connected you can see what command line options to use. In the menu: "More options..." -> "Generate success report". I wrote a bit about this in the blog post I mentioned.
    – Frepa
    Jan 6, 2013 at 18:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.