4

I am working in a pygtk project with Gtk2. As part of modification I need to include Gstreamer 1.0 instead of 0.1. In my old system can use

import sys, os, os.path, time
import pygst
pygst.require("0.1")
import gst

But I don't know how to add new version of GStreamer ... I try above one with change in version as

 import sys, os, os.path, time
 import pygst
 pygst.require("1.0")
 import gst

but got error as

pygst.require("1.0") File "/usr/lib/python2.7/dist-packages/pygst.py", line 57, in require raise RequiredVersionError, "Only version '%s' is available" % _pygst_version pygst.RequiredVersionError: Only version '0.10' is available

Please advise how can include new version fine...

1

You can't use GStreamer 1.x in Python together with the old GTK2 Python bindings. GStreamer 1.x uses a newer version of pygobject than what pygtk2 requires, and they both conflict and unfortunately the GTK team did not release a pygtk2 version that works with the newer pygobject although they're still maintaining GTK2.

You'll have to upgrade to GTK3 at the same time as updating to GStreamer 1.x.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.