0

I have installed NOOBS on a Raspberry Pi B+ and it has worked for for 15-20 days. But now it will not boot. The Green LED light blinks 2-3 times and goes off and didn't blink after that.

Please help me to resolve this issue.

Please also help to backup my data save in memory card.

  • The first test is to use another fresh build SD card and try to boot. You have a pretty good possibility of a damaged file system on your card. If a new o/s works fine, you may try to recover data mounting the old card in a usb-carrier. General advise is to use very good quality SD cards. – fcm Mar 2 '16 at 13:32
  • I already try to install new os bus getting same issue as well when i use another memory card. I use Kingston and Sandisk memory cards – ANKIT JAIN Mar 2 '16 at 13:37
  • 'same issue' = Not booting? If this is the case, then the problem is on your RPi hardware, also, double check your power supply. – fcm Mar 2 '16 at 13:52
1

2 flashes mean that the SD card cannot be read.

3 flashes mean that the file start.elf cannot be found.

Either both of your SD cards are damaged or your Raspbian image is bad. Get a known working SD card, download a fresh copy of Raspbian, then flash the image on the SD card (or copy the files if you are using NOOBS).

But before you do that, plug in your SD card on a Linux machine (VM or real). It will recognize the card if it's not corrupted and it will show up as a normal flash drive. Just copy your files.

  • when i plug sd card in windows laptop it show 800mb FAT part and when i plug in a linux system i can see only 2 part but root partition not found there. – ANKIT JAIN Mar 3 '16 at 5:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.