0

When I check the overclock options on my RBPi 2 Model B V1.1 (BCM2709, revision a01041) with Raspbian installed through NOOBS, I only see 2 overclock options. I thought there would be around 5 options or so. Why am I only seeing 2?

overclock_options_rbpi

1

I thought there would be around 5 options or so.

There are, for the BCM2835 models (A/B/+) -- "none" plus four more.

If you look at the source for raspi-config (or "a" raspi-config, there are quite a few of them on github, this has the most forks but I don't know which is the most "official" since the Foundation's own github page does not have one at all), you find:

do_overclock() {
  whiptail --msgbox "\
Be aware that overclocking may reduce the lifetime of your
Raspberry Pi. If overclocking at a certain level causes
system instability, try a more modest overclock. Hold down
shift during boot to temporarily disable overclock.
See http://elinux.org/RPi_Overclocking for more information.\
" 20 70 1
  OVERCLOCK=$(whiptail --menu "Chose overclock preset" 20 60 10 \
    "None" "700MHz ARM, 250MHz core, 400MHz SDRAM, 0 overvolt" \
    "Modest" "800MHz ARM, 250MHz core, 400MHz SDRAM, 0 overvolt" \
    "Medium" "900MHz ARM, 250MHz core, 450MHz SDRAM, 2 overvolt" \
    "High" "950MHz ARM, 250MHz core, 450MHz SDRAM, 6 overvolt" \
    "Turbo" "1000MHz ARM, 500MHz core, 600MHz SDRAM, 6 overvolt" \
    "Pi2" "1000MHz ARM, 500MHz core, 500MHz SDRAM, 2 overvolt" \

Seems slightly different (perhaps yours was tailored to the Pi 2) but there's only one applicable option there other than the default.

Note you can try whatever you want in config.txt, I believe. At some point you void the warranty though (and yes, they can determine that afterward).

  • Thanks. I specified the version of my rbpi. Does your answer still apply? – bartificial Mar 3 '16 at 9:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.