11

I have the new Raspberry Pi 3 and trying to run Snappy on it. I know that there is a 100% compatibility between 2 and 3 but Sanppy fails to boot on 3 (rainbow screen no IO light flashing).

Has anyone tried running Snappy on 3?

5
  • could be the SD card maybe, does it work in a pi2 (if you have one)
    – Havnar
    Commented Mar 3, 2016 at 11:28
  • Unfortunately I don't own a Pi 2. Could it be the CPU Arch difference (A7 vs A53)?
    – Khash
    Commented Mar 3, 2016 at 12:51
  • just a fyi. I got a Raspberry Pi 3 and gave it a tried it last night. It doesn't work. I was able to get Ubuntu MATE to work on Pi3 as an interim solution while I wait for the Snappy Ubuntu Core, but it was 8GB big.
    – dougo
    Commented Apr 27, 2016 at 16:21
  • update 05/16/2016 it doesnt work, ive just testet it. dd'd the image via rufus and win32 disk imager, both times stuck in rainbow screen like the author said. looks like the kernel image is missing, but i have no clue. im going to try ubuntu mate 16.04 now, i would rather use snappy.
    – user46619
    Commented May 16, 2016 at 16:49
  • Possible duplicate of Raspberry PI not booting Snappy Ubuntu Core
    – nu everest
    Commented Apr 21, 2017 at 20:42

1 Answer 1

10

As of this time, the rpi3 is not supported by Snappy. Canonical engineers got the device at the same time as everyone else (and it's in demand!), and this takes some time. Currently only the rpi2 is supported (among other non-rp devices, of course).

Update as of 05/13/16: The rpi3 can actually run the rpi2 image now, but it's still 32-bit. Progress is being made on enabling 64-bit, but rpi didn't make that very easy.

Update as of 10/27/16: The rpi3 is officially supported along with the rpi2. Ubuntu Core 16 has reached release candidate, and images are available for all supported platforms.

Note that the rpi3 image is still 32-bit, though progress is being made on a 64-bit image.

5
  • Is this still true ?!
    – abourget
    Commented May 13, 2016 at 21:27
  • Thanks for asking-- I updated the answer with a small update :) .
    – kyrofa
    Commented May 14, 2016 at 3:14
  • 2
    May I suggest that you provide a link to where this progress can be observed? This way people don't have to ask every month whether it's supported or not.
    – Howie
    Commented Aug 2, 2016 at 7:31
  • 1
    I'm afraid there's no such link. The best I can offer is the #snappy channel on freenode.
    – kyrofa
    Commented Aug 2, 2016 at 23:57
  • I just updated the answer to indicate that the rpi3 is now an officially supported device for Ubuntu Core.
    – kyrofa
    Commented Oct 27, 2016 at 15:57

Not the answer you're looking for? Browse other questions tagged or ask your own question.