7

i'm rather new to Linux and all that, in fact the Raspberry Pi 3 i just got is the first Linux-only machine i ever had, running the latest version of Raspbian .. so here's my problem:

I'm trying to use the integrated wifi adapter to establish a connection to my network / the interhet.

I do see my network showing up and i can try to connect to it, but it keeps either doing nothing (if i use the GUI thingie in the top right corner of the screen [sorry, i'm sure it has a propper name but i couldnt see any]) or it sais that the authentication failed when i try it with wpa_gui

Now here are my specs, i hope i get everything in there that is needed:

ifconfig -a says:

eth0      Link encap:Ethernet  HWaddr b8:27:eb:6e:78:19  
      inet addr:192.168.0.163  Bcast:192.168.0.255  Mask:255.255.255.0
      inet6 addr: 2a02:810a:11c0:2c8c:dfe1:d49f:7f8c:a4a1/64 Scope:Global
      inet6 addr: fe80::eac9:60d9:4260:247c/64 Scope:Link
      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
      RX packets:8277 errors:0 dropped:0 overruns:0 frame:0
      TX packets:7779 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000 
      RX bytes:6894047 (6.5 MiB)  TX bytes:1298763 (1.2 MiB)

lo        Link encap:Local Loopback  
      inet addr:127.0.0.1  Mask:255.0.0.0
      inet6 addr: ::1/128 Scope:Host
      UP LOOPBACK RUNNING  MTU:65536  Metric:1
      RX packets:136 errors:0 dropped:0 overruns:0 frame:0
      TX packets:136 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:0 
      RX bytes:11472 (11.2 KiB)  TX bytes:11472 (11.2 KiB)

wlan0     Link encap:Ethernet  HWaddr b8:27:eb:3b:2d:4c  
      BROADCAST MULTICAST  MTU:1500  Metric:1
      RX packets:517 errors:0 dropped:517 overruns:0 frame:0
      TX packets:30 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000 
      RX bytes:165242 (161.3 KiB)  TX bytes:5325 (5.2 KiB)'

my etc/network/interfaces file i modified quite a few times already, trying out several things, currently its looking like this:

source-directory /etc/network/interfaces.d
auto wlan0
iface eth0 inet manual
allow-hotplug wlan0
iface wlan0 inet manual
    wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf

iface default inet dhcp

and the etc/wpa_supplicant/wpa_supplicant.conf has this here:

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1

network={
    ssid="MySSID"
    psk="MyPsk"
    proto=RSN
    key_mgmt=WPA-PSK
    pairwise=TKIP
    auth_alg=OPEN
}

The network i am trying to connect to is WPA2 PSK encrypted with TKIP, my only guess here is that i have to make some settings either in Raspbian's wpa_supplicant.conf or in my router to let the two of them communicate with each other?

Or am i missing something totally obvious here?

I would also be grateful for hints on what tools i can use under Linux to figure this problem out and see where what goes wrong :)

Thanks a lot in advance and sorry if i messed up any english ;)

  • You are using obsolete settings. If you unplugged the Ethernet it may work, but you would be better to use the recommended settings. See How do I set up networking/WiFi/Static IP – Milliways Mar 4 '16 at 22:06
  • I'm getting a little worried about my Pi 3, now that I'm seeing so many internal wifi questions about it... – Patrick Cook Mar 5 '16 at 2:20
  • @Milliways thanks a lot for pointing out that i had obsolete settings, the tutorial you linked was very helpful, it could well be that i couldnt have solved it without it :) – Virus Ex Mar 5 '16 at 9:58
  • @IgorGanapolsky Pretty sure he just meant "says", I submitted an edit to the answer. – Ken Williams Oct 7 '17 at 21:21
5

I solved the problem.

First I updated my settings as suggested in the link that Miliways provided in a comment in my original answer.

That alone didn't solve it, what I actually had to do is change the configurations in my router:

The WiFi was set to WPA2/WPA -> I changed that to WPA2 only and now I can finally connect to the network without problems.

If there are configs that I would need to adjust in order to make WiFi work with WPA2/WPA settings in the router, I would be glad if anyone could provide these, I couldn't find anything considering that on the internet.

  • Worked for me too. – Alex Juchna Sep 1 '16 at 20:09
  • 1
    Worked for me as well. I found out how to make it work with mixed WPA2/WPA. I had to edit /etc/wpa_supplicant/wpa_supplicant.conf and change CCMP to CCMP TKIP in both the pairwise= and group= settings. – Pedro Gimeno Aug 2 '18 at 22:18
  • @PedroGimeno Could you please post a sample? I'm new to this and I don't see any pairwise setting and my group= setting is set to netdev, not CCMP. Thanks! – Zain Rizvi Jan 3 at 8:00
  • See man wpa_supplicant.conf. In the EXAMPLES section the first example has two network= sections; the second one uses what I say above for pairwise and group. Note it's the group inside network that you need to change or add, not the GROUP at the top. – Pedro Gimeno Jan 3 at 12:32
1

I've had problems before with using a pre-shared key, especially when I forgot to escape characters that needed to be escaped. Characters that may need to be escaped would be (among others):

{}\[]<>?;~@"

You escape a character by adding a '\' before it, so for example if your key was:

P@ssword"!

You would escape it like:

P\@ssword\"\!

Likewise, if you needed the character \ in your password, you would escape it by prefixing like \\.

In this case, you haven't shared the key (good!), but have you made sure that it's properly escaped? If possible, could you change it to a key that's only alpha-numeric and try for troubleshooting purposes?

I don't see anything in the configuration that you've provided that points to any other configuration issue.

  • oh that is a really good tip, i did not know that you had to escape such characters in a PSK, however, mine only consists of upper and lowercase characters and numbers. but thanks for looking into the config as well, im happy that i didnt mess it up with my changes atleast :) – Virus Ex Mar 4 '16 at 18:07
  • What about & and *, do those need to be escaped? – IgorGanapolsky Jul 18 '16 at 1:01

protected by Community Sep 1 '16 at 20:43

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.