0

I am facing a rather weird problem with SSH.

When I SSH into my raspberry pi 2 from my windows laptop, it works properly for some time and after that whatever I type only appears after a very long delay. I tried to ping the Pi while I am typing the command over SSH and the ping is usually either 2ms or 3ms. I am using the bash terminal I got when I installed git on this laptop. I think its MING64. this laptop is connected to the modem via WiFi. It does not have an Ethernet port and I do not have an adapter so i was unable to check if i get the same problem over Ethernet.

I tried to SSH from another laptop running Ubuntu. this laptop is connected over Ethernet and it does not have any delay when I type. I have kept the SSH connection open for more than 10 minutes as I used it and it hasnt slowed down at all. in fact it feels like I'm using the terminal normally and not over SSH. When I pinged the Pi from this laptop while I was connected to the pi via SSH, the ping is higher (around 3-4 ms).

I know that the typing delay is usually caused by higher latency but in my case the laptop with higher latency has a smoother connection than the one with lower latency.

Are there any other factors which could be causing this strange behaviour? I would prefer to connect to the Pi from my windows system.

I used to run openelec on the Pi until last week and if I remember correctly, I did not have any typing delay the few times I SSHed into the system. Is this a problem with OSMC?

Any help would be greatly appreciated, thanks

  • Which software are you using on Windows for ssh connections? – edumgui Mar 7 '16 at 12:03
  • its a bash terminal that came with git I believe its MING64, thats what it says on top when i use the terminal – Rumesh Mar 7 '16 at 12:36
  • Try Putty for terminal or MobaXterm if you need X forwarding. I've been using them for years without an issue. – edumgui Mar 7 '16 at 12:40
  • All right ill give it a try and let you know if it works out or not when i get the chance – Rumesh Mar 7 '16 at 13:44
  • Try disabling auto update checks, and check 'top' to see if something is amiss. – user1133275 Mar 9 '16 at 2:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.