1

I've searched high and low for some kind of solution to my problem, but it seems NO ONE experiences this!? I'll admit, everything was working fine up until some random point (so frustrating, I have no idea what I changed!)

Essentially my bluetooth works flawlessly except for the fact that upon reboot, all my previously paired devices are now forgotten! I now have to manually go through the process of pairing them again before reusing them...

It appears to have nothing to do with whether or not I trust the devices.

I've tried uninstalling/reinstalling all bluetooth related packages. No luck.

I've also tried pairing from GUI as well as with bluetoothctl from the command line, either way, devices are forgetten upon reboot.

I've browsed the /var/lib/bluetooth directory. The hint seems to be here...there used to be two devices linked here before. However, they were not being used by whatever process that is in charge of "remembering" devices. In an attempt to fix the situation, I deleted everything found under the directory, hoping to repopulate it. And lo-and-behold, no activity! So it seems whatever used to be reading/writing to this directory has now broken this link!

Any ideas??

This is using a Raspberry Pi 2 board, with an inateck BTA BC4B6 (broadcom chip) USB dongle

1

OK, managed to solve this one!

I played around with the permissions to the /var/lib/bluetooth folder:

chmod -R a+rwx /var/lib/bluetooth

chown -R pi:root /var/lib/bluetooth

And now everything works as before!

I'm still not sure what I did to cause this, or what it originally changed the permissions to that broke it...

  • 1
    I think you may mean /var/lib/bluetooth rather than /lib/var/bluetooth ? – JosephH Mar 6 '16 at 18:58
  • yes, you're correct. Edited post to reflect this. – SProj Mar 9 '16 at 2:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.