1

I installed today my Raspberry again. And after installing updates and normal packages like vim I rebooted it. Now it boots, you see all the processes running (normal boot procedure) but then it's stuck. After that it never shows the desktop like it should, there is just a blinking underscore no CLI or something. I saw this issue and therefore I'll try not to run it for a few days but I'm wondering if anyone else knows something about this issue.

Edit:

I was installing updates and vim when I tried open webpages in the browser. It always closed the browser window as I opened websites. So I thought I might just reboot.

  • What SD card are you using as your boot device? Also what OS did you install onto the SD card? And the software you used to install the OS? – Darth Vader Mar 6 '16 at 19:46
  • Kingston 32GB micro SD, I used the Raspbian Jessie build and Win32DiskImager – Tem Mar 6 '16 at 20:01
  • OK nothing there that should cause any boot problems, your Pi was booting correctly before any updates or programs were installed? – Darth Vader Mar 7 '16 at 8:27
  • Yes booted it a few times before that happened without any problems. Also the browser always closed when I tried to open a page, that was while updating and installing vim. I thought I might just reboot and it will work again. – Tem Mar 7 '16 at 9:09
  • Did you waited for apt-get install to complete? If not, the easiest way is to image sdcard and start again... – edumgui Mar 7 '16 at 11:45
0

What might have happen to you is that you have actually ran out of disk space. When you install Raspbian by just copying the image onto the SD card, it usually keeps the original partition size which is more like 2 GiB than 32 GiB of your card. Then, if not enough space is available, X (graphical UI) won't boot. Maybe you are looking at a terminal that failed to boot graphically.

If you are still able to log into a text terminal, by pressing Ctrl-Alt-1 for example, try checking the output of df -h. It should show a partition mounted at /, and let's hope the free space is in megabytes or gigabytes rather than 0 or bytes.

If this is your problem (free space is 0 or close), what you need to do is called expand rootfs to fill the whole SD card. Running

sudo raspi-config

should show you an option to do so.

  • Hello and welcome. Please note that you can roll-back my copy edit, just in case you do not like it... – Ghanima Mar 7 '16 at 21:09
  • Maybe I missed a message like such you mentioned. I have set my raspi up again so I can't test your suggestion. But thanks anyway! – Tem Mar 10 '16 at 7:57
  • It often happens without a clear message. Simply when the free space reaches 0, things suddenly start failing, not always with a easy to notice message. – ikari Mar 10 '16 at 13:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.