Got a Pi 3 which will always use ethernet, so trying to figure out how to disable the WiFi such that it does not even turn on after a reboot.

If I do an ifconfig I see the wlan0 device. I can do ifconfig wlan0 down but it will come back up again after a reboot.

I tried commenting out anything about wlan0 (and wlan1) in /etc/network/interfaces but that has not made a difference.

eth0 is not commented out so it can be used.

  • Did you comment out the wlan1 in that file as well? – Patrick Cook Mar 8 '16 at 6:23
  • Yes. Only left lo and eth0. – Evan Mar 8 '16 at 6:24
  • 1
    What is the setting for wlan0 in /etc/network/interfaces? If it is auto change it to manual followed by ifdown wlan0. – ott-- May 29 '16 at 20:07
  • Thanks, @ott. You just reminded me how to have the internal one stop grabbing a DHCP address while the USB WLAN unit connects with static. I just commented out the wpa_supplicant line and added ifdown wlan0 - Thanks again. – SDsolar Jul 17 '17 at 8:18
up vote 28 down vote accepted

This post seems to be talking about this. The answer talks about disabling the drivers by editing the file /etc/modprobe.d/raspi-blacklist.conf and adding:

blacklist brcmfmac
blacklist brcmutil

Alternatively, you could use crontab -e and add:

@reboot sudo ifdown wlan0

So that command runs at each boot.

Hope this helps, I'm still waiting for my Pi 3 to arrive.

  • 4
    The blacklist method worked for me. Just created a /etc/modprobe.d/local-blacklist.conf file, instead of appending to an existing file. – Evan Mar 8 '16 at 6:47
  • As far as I know, the blacklist method is closer to administratively down'ing the interface. It does not completely power down the interface. – jww Aug 5 '16 at 20:51
  • 2
    @Patrick Cook Second method worked for me but I needed to run that command as root: sudo crontab -e – Matthias Herrmann Mar 21 '17 at 8:38
  • I like using the crontab to do it. As a matter of style I would edit the root crontab instead of any other user, and leave out sudo. For stretch, you need to use ip link set wlan0 down instead of ifdown – threeve Jun 13 at 17:51

To completely disable the onboard WiFi from the firmware on the Pi3, add

dtoverlay=pi3-disable-wifi

in /boot/config.txt. This is documented here

Please be sure to use an up to date firmware as this feature was committed recently. Also, there is an overlay for disabling onboard bluetooth : pi3-disable-bt.

  • 12
    Correct. /boot/config.txt is the cleanest possible way to disable WiFi, and other peripherals. – Andrejs Cainikovs Mar 14 '17 at 12:50
  • 5
    Yes! The accepted answer will get you there, but this is a much better way. – Clay Mar 23 '17 at 11:01
  • How would you use this method to disable ethernet? – Daniel Harris May 23 '17 at 17:30
  • 1
    At the time that I wrote my answer (the current accepted one) I did not know of this way, nor do I know if it was even an option at that time. This is a far superior method than the one described in my answer. – Patrick Cook Jul 2 at 2:45
  • 1
    The overlay did not exist at the time you wrote your answer. As stated in my response, this was added on January 2017. So don't worry, you were right ! – Ludovic Ronsin Jul 2 at 13:39

You can try

sudo iwconfig wlan0 txpower off

This should disable the wifi adapter.

  • no , actually it does permanenty close the adapter until you made it back on again – yavuzaksan Jul 30 '16 at 14:25
  • I'll take your word for that then. In future you might want to include more explanation in your answer, since this got automatically flagged yesterday as "low quality" (due I think to length and lack of formatting) by the system, which is when I noticed it. In itself that sort of doesn't matter; I dismissed the flag. However, a moderator can dismiss a flag (not act on it) as "helpful", and if it was a "low quality" flag, that automatically gets you a downvote... – goldilocks Jul 30 '16 at 14:44
  • ...I didn't do that, but one of the other mods probably did out of habit (or because they agreed the answer as originally posted did not indicate much effort being made), which is how you got one down vote (automatic) and one up (from me), since flags are sometimes left for review by multiple mods. Note I don't like this "automatic downvote" policy and have actually complained on S.E. Meta about it to no avail (the justification is that actual people flag things as low quality but "forget" to also downvote). – goldilocks Jul 30 '16 at 14:44
  • 1
    @yavuzaksan I can't seem to turn it back on, now. – Erutan409 Mar 10 '17 at 5:28
  • 2
    @Erutan409 to re-enable the wifi adapter you should write two times "sudo iwconfig wlan0 txpower auto". but as a say you should write it two times otherwise it wont work (i believe there is some glitch in the firmware) – yavuzaksan Mar 11 '17 at 6:25

Apart from blacklisting which has the risk of a lockout in case you need to reboot and no ethernet is available, you can also unload the kernel module as follows:

sudo modprobe -r -v brcmfmac

But I'm not sure unloading the device drivers is a good idea as I fear the wlan0 device may still draw power and even more so if the device drivers' power management features are not loaded, currently I keep drivers loaded and simply make sure the default route via wlan0 is disabled:

sudo ip route del default via <Gateway IP> dev wlan0

This will make sure all traffic will go via eth0 and (hopefully) be more stable and so forth for example for the ntp daemon.

We have measured the RF from the Pi 3 (when used as a WiFi hotspot) and confirmed that this statement disables the Pi's WiDi transmitter when used as a hot spot:

sudo ifconfig wlan0 down

You can also easily create a clickable button on the taskbar to do this. Instructions are found here: http://orbisvitae.com/ubbthreads/ubbthreads.php?ubb=showflat&Number=81166#Post81166

I'm using my pi as an access point (wifi hotspot). This works for me:

# Turn off
sudo service hostapd stop && sudo service isc-dhcp-server stop && sudo ifconfig wlan0 down

And to turn it back on without restarting the pi, run this:

# Turn on
sudo ifconfig wlan0 up && sudo service hostapd start && sudo service isc-dhcp-server start

I use the following command wpa_cli terminate, I have that command in my /etc/rc.local

  • 1
    This disables the WPA client, so you basically shut down wireless connectivity entirely. Don't do it. – Zimano Oct 30 '17 at 11:28

I modified the rc.local using command sudo nano /etc/rc.local, and added ifconfig wlan0 down in it. However, if Ethernet is not connected or IP is not assigned to wired interface then the WiFi is on. This gives a backup way to connect the RasPi when running headless.

it looks like as below,

_IP=$(hostname -I) || true
if [ "$_IP" ]; then
  printf "My IP address is %s\n" "$_IP"
fi

# Disable WiFi if wired.
logger "Checking Network interfaces..."
if ethtool eth0 | egrep "Link.*yes" && ifconfig eth0 | grep "inet addr"; then
  logger 'Disabling WiFi...'
  ifconfig wlan0 down
else
  logger 'WiFi is still enabled: Ethernet is down or ethtool is not installed.'
fi

exit 0

Then save using CTRL + X and reboot. It seems to work for me, as after reboot ifconfig does not give wlan0.

The easiest way to disconnect from a Wifi network on Pi 3 is to enter some useless password! Click on your Wifi network, it will again ask for password but this time enter random text and you will be disconnected.

  • 4
    There is a difference between having an interface enabled, a device enabled (which this question is about), and having an interface connected to a network, which is what you are talking about. I do not think the OP is concerned about that. – goldilocks Jul 18 '16 at 16:22
  • @goldilocks Well if Wifi is disconnected this way then it will always use Ethernet and that is what OP is asking for. – Chinmay Sarupria Jul 18 '16 at 16:26
  • Or edit using sudo nano /etc/wpa_supplicant/wpa_supplicant.conf for those wanting to use this method. – 101 Oct 19 '16 at 9:21

protected by Community Apr 27 at 17:12

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.