1

I have both eth0 and wlan0 actives, can ping both, can run RDP to both IPs (192.168.0.101 for eth0, 192.168.0.102 for wlan0).

Ssh to eth0 works OK, ssh to wlan0 works OK as long as I have eth0 connected to the router. If I disconnect eth0 and run ssh (Putty, from windows) it hung after typing password. Wlan0 respond to ping, RDP works ok. :/

If I run a sudo service ssh status on my RPi I get that the session is opened.

Any suggestion?

/Alejandro

1
2

looks the DNS issue : after you're unplugging eth0 your OS still tries to use it's DNS servers, especially if you have a DHCP on eth0. Add/change in `/etc/ssh/sshd_config :

UseDNS no

and restart your system to take effect. Also it would be useful if you'll post your sshd_config

1
  • this also helped me, thanks – DWils Sep 15 '20 at 1:06
1

You have eth0 and wlan0 both connected to the same router and both connections are working as you can see if you ping its ip addresses. But the kernel can only use one connection at a time if you use a stateful tcp connection. This is the case with ssh. It starts a password enabled authenticated session on one connection to its destination ip address, e.g. to 192.168.0.101 for eth0. This must be available as long as the session is established (until logoff). If you disconnect eth0 then ssh hangs. It will not switch to use 192.168.0.102 for wlan0. To achive this you have to use a connection with dynamic fail over.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.