2

I installed PhpPgAdmin on the Pi and want to access its database from my laptop.

If I type on my laptop's browser http://192.168.1.97/phppgadmin, 192.168.1.97 being the inet adress of my Pi, I get a message from Apache saying

You don't have permission to access /phppgadmin on this server.

How can I change that permission?

  • You could try using Filezilla or WinSCP. I've used Filezilla to remotely access files through SFTP with no issues. – C-dizzle Mar 8 '16 at 17:44
  • Solved it myself. Run the command: sudo nano /etc/apache2/phppgadmin.conf and comment the line "Require local" it will allow you to access from http://<Rpi-inet-adress>/phpphadmin – Diogo Magalhães Mar 8 '16 at 18:02
  • @C-dizzle: sftp isn't helpful if you want to access a database. – Jacobm001 Mar 8 '16 at 19:16
1

Solved it myself. Run the command: sudo nano /etc/apache2/phppgadmin.confand comment the line "Require local" it will allow you to access from http://[Rpi-inet-adress]/phpphadmin

0

You can permit all networks access;

sed -i .bak 's/^(Require local)/#$1/' /etc/apache2/phppgadmin.conf

or a more secure option is to use a SOCS 5 proxy so your browser is considered local;

ssh -fND 127.0.0.1:8080 pi@192.168.1.97 2>/dev/null >&1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.