3

I use Raspberry Pi 3 with image "RASPBIAN JESSIE" which is 2016-02-26 build. I plug in micro-usb to power on. Then I use USB to TTL adapter to try to login. I've set baud rate 115200, and connect GND, Pi's TXD0 to TTL's RX, Pi's RXD0 to TTL's TX. But I only saw mojibake. I've tried other usual baud rate and comes same results. I also try use this image on Pi 2, and it behaves normally. Does anyone knows how to login with uart on Pi 3?

3

I found answer here: https://openenergymonitor.org/emon/node/12311

Briefly it's due to Pi 3 default enable bluetooth which supplants uart on GPIO 14/15. So we need to disable bluetooth.

  • I can confirm this is still the case on the March 15 (2016) release of Raspbian Jessie and Jessie Lite. Great Answer. – Patrick Cook Mar 23 '16 at 0:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.