I have recently bought a Raspberry Pi 3 and trying to set up SSH with my MacBook. Although I have a good internet connection on both, I can't even ping my Raspberry Pi from my laptop or vice versa, let alone connect with SSH. I've already read countless similar questions and tried their answers, however nothing has worked.

First I tried to give both my MacBook and Raspberry Pi a static IP address, since I thought the problem might be that my router periodically changes the IP addresses. This did not help, although I was able to ping my laptop from the Raspberry (still not the other way around). Next thing I tried fiddling with /etc/network/interfaces settings, no result either.

ifconfig gave me:

eth0      Link encap:Ethernet  HWaddr b8:27:eb:ef:cd:5c  
      inet6 addr: fe80::79d:4936:97e0:7549/64 Scope:Link
      UP BROADCAST MULTICAST  MTU:1500  Metric:1
      RX packets:0 errors:0 dropped:0 overruns:0 frame:0
      TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000 
      RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lo        Link encap:Local Loopback  
      inet addr:  Mask:
      inet6 addr: ::1/128 Scope:Host
      UP LOOPBACK RUNNING  MTU:65536  Metric:1
      RX packets:72 errors:0 dropped:0 overruns:0 frame:0
      TX packets:72 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:0 
      RX bytes:6288 (6.1 KiB)  TX bytes:6288 (6.1 KiB)

wlan0     Link encap:Ethernet  HWaddr b8:27:eb:ba:98:09  
      inet addr:  Bcast:  Mask:
      inet6 addr: fe80::ba27:ebff:feba:9809/64 Scope:Link
      inet6 addr: 2001:984:9021:1:ad53:7ed1:e2f8:a698/64 Scope:Global
      RX packets:2056 errors:0 dropped:1353 overruns:0 frame:0
      TX packets:753 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000 
      RX bytes:642898 (627.8 KiB)  TX bytes:84266 (82.2 KiB)

I've also tried port forwarding to see if that was the issue (i.e. using port 55555 instead of port 22). When I try to ping my Raspberry Pi from my laptop I get the message ping: sendto: Host is down

Confusing thing is both computers have access to the internet, can ping their own IP addresses and can ping the router, just not each other. Any ideas?

  • Unless you tell us what you tried (include output of ifconfig) no one can help.
    – Milliways
    Mar 10, 2016 at 9:55
  • Thanks for the input, as I've said I'm a bit of a noob so still getting used to things. Hopefully this is better now. Mar 10, 2016 at 10:44
  • It might be the router's configuration.
    – nwaltham
    Mar 10, 2016 at 11:42
  • You still seem to unwilling or unable to say what you have actually done. If you can undo all the fiddling you have done you should be able to ssh to the Pi with ssh [email protected] (provided the Pi is in a default state).
    – Milliways
    Mar 10, 2016 at 12:26
  • Of course I have tried this. I undid all the fiddling simply by reinstalling Raspbian (since I hadn't done anything with my Pi yet anyway). Whenever I try to SSH I get the error ssh: connect to host port 22: Operation timed out. Changing the port did not help this. I'd like to add that I am not unwilling to say what I've done, as I don't know why I would be. I am new to this community however, so I suppose that is the problem. Mar 10, 2016 at 15:06

2 Answers 2


First see if you can do a "ping" from the Raspberry Pi and the Mac, and then a "ping" from the Mac to the Raspberry Pi. Because if those things won't work, ssh won't either.

  • Indeed none of these things worked, but I don't understand why; both are connected to my router and my router can detect them both. For some reason they just aren't connected to each other. If I try to ping I receive the error ping: sendto: Host is down. Mar 10, 2016 at 17:17

Interesting. It looks like your router is doing two connections with two iv6 addresses. Does your router do "ac"? If so, which ip address do you ssh to when a router does a dual channel ac connection?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.