0

i tried following the directions here for the watchdog Link: http://pi.gadgetoid.co.uk/post/001-who-watches-the-watcher

i can't get even past the first attempt, here's an SS: http://prntscr.com/ohvq1 , i tried adding the line bcm2708_wdog but wrong characters come out or when i press some keys different ones appear like here's an SS: http://prntscr.com/ohvvj , is this normal? i don't really know what to do, still a noob linux user here.. hope someone will help thanks again. please comment first if the question isn't enough.

  • 5
    It would appear you don't know how to use vi. It might be easier to try with, e.g., nano instead until you have the time to learn. – XTL Jan 8 '13 at 8:49
  • 3
    10 second vi primer... First, use vim. Second, type i before trying to insert anything. Third, type ESC to get back to control mode. Fourth, type :x to save and exit. Fifth, Google it. – Alex Chamberlain Jan 8 '13 at 9:17
  • Have you solved this issue yet? If so, could you please create a self-answer and mark it as such. We are trying to get the Q:A ratio up and that would help us a ton. Thanks! – RPiAwesomeness Mar 3 '14 at 17:59
  • you don't need editor to add just 1 line to a file. Use echo. sudo echo "bcm2708_wdog" >> /etc/modules should work. – gurcanozturk Sep 16 '14 at 18:53
1

You seem to have issues with vi or vim. Either you learn how to use vi/vim, or you use a less advanced and much simpler editor like nano.

If you want to edit /etc/modules then you'll have to do it as a superuser, ie

sudo nano /etc/modules

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.