2

I was able to ssh into my raspberry pi with no problem for some time.

Today, however, it has just stopped working and I don't know why.

Initially, I thought it might be a problem with my router's mDNS,

 😈   >ssh -l pi alexpi.local
ssh: Could not resolve hostname alexpi.local: nodename nor servname provided, or not known

but then I discovered that I couldn't ssh to the raw IP address either.

 😈   >ssh -l pi 192.168.86.130
ssh: connect to host 192.168.86.130 port 22: Operation timed out

The ssh daemon appears to be running okay on the pi ...

pi@alexpi ~ $ sudo service ssh status
● ssh.service - OpenBSD Secure Shell server
   Loaded: loaded (/lib/systemd/system/ssh.service; enabled)
   Active: active (running) since Thu 2016-03-10 11:39:31 PST; 3min 43s ago
 Main PID: 546 (sshd)
   CGroup: /system.slice/ssh.service
           └─546 /usr/sbin/sshd -D

Mar 10 11:39:31 alexpi systemd[1]: Started OpenBSD Secure Shell server.
Mar 10 11:39:32 alexpi sshd[546]: Server listening on 0.0.0.0 port 22.
Mar 10 11:39:32 alexpi sshd[546]: Server listening on :: port 22.
pi@alexpi ~ $ 

Then I discovered that I can't even ping the thing.

 😈   >ping 192.168.86.130
PING 192.168.86.130 (192.168.86.130): 56 data bytes
Request timeout for icmp_seq 0
Request timeout for icmp_seq 1
Request timeout for icmp_seq 2
Request timeout for icmp_seq 3
^C
--- 192.168.86.130 ping statistics ---
5 packets transmitted, 0 packets received, 100.0% packet loss

This makes no sense because

  • the pi is on the same wifi network as my laptop AND
  • I am able to access the internet from my pi AND
  • I am able to ping my laptop from the pi (however it does give a strange error before it succeeds in pinging)

Here's what the ping from pi to laptop looks like ...

pi@alexpi ~ $ ping 192.168.86.111
PING 192.168.86.111 (192.168.86.111) 56(84) bytes of data.
From 192.168.86.130 icmp_seq=1 Destination Host Unreachable
From 192.168.86.130 icmp_seq=2 Destination Host Unreachable
From 192.168.86.130 icmp_seq=3 Destination Host Unreachable
64 bytes from 192.168.86.111: icmp_seq=4 ttl=64 time=22.3 ms
64 bytes from 192.168.86.111: icmp_seq=5 ttl=64 time=44.6 ms
64 bytes from 192.168.86.111: icmp_seq=6 ttl=64 time=2.37 ms
64 bytes from 192.168.86.111: icmp_seq=7 ttl=64 time=89.0 ms
64 bytes from 192.168.86.111: icmp_seq=8 ttl=64 time=1.86 ms
64 bytes from 192.168.86.111: icmp_seq=9 ttl=64 time=137 ms
64 bytes from 192.168.86.111: icmp_seq=10 ttl=64 time=2.66 ms
^C
--- 192.168.86.111 ping statistics ---
10 packets transmitted, 7 received, +3 errors, 30% packet loss, time 9004ms
rtt min/avg/max/mdev = 1.869/42.971/137.810/48.562 ms, pipe 3
pi@alexpi ~ $ 

Something is clearly impeding connectivity, but I'm not sure what it is.
I'm not even sure if the problem is on the pi or with my wifi router?
I don't believe that I made any changes to either between the time that it was working and when it stopped working.

UPDATE: rebooting the pi did not solve the problem.
However, rebooting my wifi router did. (for now)
So the problem appears to be with my Google Asus OnHub router. Though, I am not certain exactly what the problem is.

  • 1
    Likely not a ssh problem if the this network host is unreachable by any protocol as you have discovered. What operating system is on the Raspberry Pi? Raspbian Jessie? Did you set a static address? Did you edit any other networking configurations? – medbot Apr 10 '16 at 22:28
  • 1
    Try 1) set the static IP address for wifi; 2) setup a wired connection on Pi. – 南山竹 May 11 '16 at 0:25
  • Can you please verify which IP you Pi has? – Orphans Dec 30 '16 at 7:55
1

If you have an Android phone or tablet lying around, install Fing scanner or NetX on it and use it to see if your Pi still has the same IP # (if it's even on line at all). If the IP # did change, be sure to edit your connection settings in your laptop's terminal app.

1

Somehow the Router problems existing too much !!!
I think you should assign static IP on your Pi for the best connection.
By the way, try to re-configure your Router DHCP Server for your laptop connection.
For example, the range 192.168.86.10 (max hosts : 50) will be for your laptop. Then you assign your Pi into static address that different from the laptop network range.

Pi# sudo nano /etc/dhcpcd.conf
Pi# sudo reboot

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.