0

I bought new Raspberry-pi model B with noobs OS .After configuring it, and login through PUTTY .I tried to log in through VNC.I done all supposed configuration till I managed to log through raspberry pi desktop.However I can not use any action using mouse or keyboard . just desktop showing up.Also I enabled input in VNC software . Any one experienced same problem or have an idea what is going on ?

  • Which VNC client are you using? Could it be due to you not capturing the mouse/keyboard on your desktop? – Matthew Dann Mar 10 '16 at 22:22
  • I'm using tight vnc – BratBart Mar 10 '16 at 22:39
  • I did use many vnc servers later and followed all instructions without any results – BratBart Mar 10 '16 at 22:42
  • Have you tried to start the vncserver like this: pi@raspberrypi$ vncserver :1 Output: New 'X' desktop is raspberrypi:1 Starting applications specified in /home/pi/.vnc/xstartup Log file is /home/pi/.vnc/raspberrypi:1.log I use TIghtvnc to view the pi, and connect to the ip like this: 192.168.0.100:1 – Ron K. Mar 12 '16 at 18:50
3

I just found the answer to MY problem, and thought I should share. I am using the RealVnc that came pre-loaded on Jessie, and had the same issue. When starting the realVNC program, before connecting to the Raspberry Pi that it detects, right-click on the connection, select "properties" and go to OPTIONS tab. The top section is "Picture quality" and a small check box that says View-Only. Mine was selected. My remote mouse and keyboard did not control the PI. I de-selected this "view-only" box and now it all works great. (makes sense afterwards)...

0

This tutorial may answer your question, since I think you want control of display :0: http://log.liminastudio.com/writing/tutorials/remote-desktop-control-of-a-raspberry-pi

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.