0

I just got a RPi, and I'm using this site to try and connect my Pi, so I allowed other users to connect via the connection, and my Pi is connected, but when I try to put the IP address into PuTTY, it says "Network Error: Connection refused". I think it may have to do with the port, because I'm just using the default in PuTTY, but I don't know what else to use.

0

If you can access your RPi directly (plug in a keyboard and a mouse), make sure the ssh service is running. Try checking sudo service ssh status (I think there is also sshd as an alias so sudo service sshd status should give the same result). If it says SSH server is not running, then this is the cause of your problem. Otherwise it might be something else (for example you put the IP of another computer that is online but doesn't have SSH). You shouldn't have to change the port number, the default is 22 and Raspbian uses the default.

  • It sounds like this is the problem - I haven't been able to access the terminal on my Pi to set up the SSH, which I thought using PuTTY might solve. But it sounds like I'll just need to set it up with HDMI? – MANA624 Mar 12 '16 at 17:30
  • 2
    HDMI connection to a television will work. You should just need to get into the configuration to enable the SSH server: "You can enable or disable the SSH server on your Raspberry Pi (it is enabled by default). This is done using raspi-config: Enter sudo raspi-config in the terminal, then navigate to ssh, hit Enter and select Enable or disable ssh server." [raspberrypi.org/documentation/remote-access/ssh/README.md] Raspberry Pi Docs – Ron K. Mar 12 '16 at 18:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.