I bought a cheap VK-QF9700 to connect to my new Raspberry PI Zero. I know the chipset (DM9601) had some problems with the Raspbian kernel that has been recently updated.

The problem I have is that if I power on the Raspberry, wait for the boot to finish and then plug the Ethernet adapter in the Micro USB, everything works fine.

But if I leave the adapter plugged in and try to boot, the adapter does not get recognized.

I run lsusb in rc.local to check if it is detected, but the command just shows me the standard USB Hub without any devices attached.

I tried resetting (with a utility I found around, usbreset) the USB hub, but nothing happens.

Any ideas?

  • I have a similar problem with other usb devices on my Pi Zero, it only seems to happen when I use certain otg adapters. Mar 12, 2016 at 18:46
  • Thank you Patrick. Did you manage to fix it in any way? I don't use any adapter,I directly attach the USB Ethernet device to the micro USB of the raspberry. Marco
    – MarcoT74
    Mar 13, 2016 at 21:26

2 Answers 2


I had the same problem with my usb ethernet adapter but I solved it in my case by removing the settings used to connect the pi over usb to my laptop.

These settings are not default however and I added these myself before.

So for raspbian Jessie this is:

  1. Go into your boot partition, it is automaticly mounted at /boot/
  2. From config.txt remove dtoverlay=dwc2
  3. From cmdline.txt remove modules_load=dwc2,g_ether

For me this solved the problem and after a reboot ethernet directly showed up. However you cannot ssh into the pi anymore using usb, which seem unneccessary anyway because you have an ethernet now.


See my post: https://forums.raspberrypi.com/viewtopic.php?t=334055 and my reply. I have the same problem with different USB to network adapters (UGREEN / BELKIN), but in my case it only is a problem when booting from an USB SSD. The Belkin adapter should work out of the box conform the rpi compatibilty list.

When I boot from SD-card no problems. You can check it with the dmesg command.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.