2

It's fun to run 'xeyes' on Raspbian - because of the big Raspberry in the middle of the desktop.

But by default if you just type 'xeyes' in a terminal : the eyes come up with extra 'decorations' on them, like this:

decorated eyes

You can switch off the decorations by clicking on the top-bar of the xeyes window, so they end up looking like this (and the it looks like the Raspberry is watching your every (mouse) move !)

enter image description here

So how can I :

a) Make them show up 'undecorated' by default and b) Have them launch when I start my desktop ?

BTW: you need to install 'xeyes' on Raspbian - they are not there by default. I used :

sudo apt-get install x11-apps

3 Answers 3

2

Wow, xeyes. Been a while since I've seen that. Have you checked out xsnow, lol? (Actually I think you have to compile that from source now, no one even distributes it).

This isn't really an answer to A or B but it is an answer to C) How to make sure it ends up in the right place when undecorated.

For an answer to B, have a look into lxde autostart, which there will be many examples of here and elsewhere online.

For an answer to A, I think LXDE uses openbox as the window manager and you might be able to configure that way, see e.g. here.

Being a traditional X app it (ostensibly) obeys the --geometry setting. That man page doesn't explain it but the setting is always of the form widthxheight+horizontal+vertical, e.g., 5x10+50+25 but you can leave the w x h out, e.g., just +50+25. It's in pixels, so will take a few minutes playing around.

I wrote "ostensibly" because the window manager could screw with it -- that's what's adding those decorations. But probably not. There may be a way to tell LXDE to not used them for xeyes in particular, I dunno. As mentioned, I'd check and see if openbox is in use (ls -A | grep openbox) and investigate that.

Once you get the geometry worked out you can actually include it in a config file called /etc/X11/Xresources (I think this still exists by default), add something like:

xeyes*geometry +100+50

If it doesn't work source it from your .xinit or similar. But it may be easier for you to just include the command line invocation in an LXDE start-up thing, or a short hand script / shell function.

2

Edit /etc/xdg/openbox/rc.xml or ~/.config/openbox/rc.xml

Set

<decor>no</decor>

for the xeyes app.

EDIT: That file didn't work so I just added some lines after the big application example comment in file that was there. ~/.config/openbox/lxde-pi-rc.xml

This puts the eyes in the center:

pi@raspberrypi2 ~ $ cd .config/openbox/
pi@raspberrypi2 ~/.config/openbox $ tail lxde-pi-rc.xml 
-->
  <application name="xeyes">
   <position force="yes">
      <x>center</x>
      <y>center</y>
    </position>
    <decor>no</decor>
  </application>
</applications>
</openbox_config>
pi@raspberrypi2 ~/.config/openbox $ 
1

In Raspbian, there is also tuxeyes if you just want to install one app and not all the X11 apps. Great for checking if X11 Forwarding is working :)

sudo apt install tuxeyes

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.