2

I am using a Plantronics USB Headset that also has a microphone. I have tried a lot of articles and finally managed to make the headphone work, but the microphone still doesn't work.

Here are current settings:

$ cat .asoundrc
pcm.!default {
      type hw
       card 1
}

ctl.!default {
        type hw
        card 1
}

List of devices shows below:

$ arecord -l
**** List of CAPTURE Hardware Devices ****
card 0: C320 [Plantronics C320], device 0: USB Audio [USB Audio]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

I tried searching for snd_usb_audio and here is the output:

$ lsmod | grep snd_usb_audio
snd_usb_audio         114378  4
snd_usbmidi_lib        19690  1 snd_usb_audio
snd_hwdep               5595  1 snd_usb_audio
snd_pcm                73442  1 snd_usb_audio
snd                    50779  15 snd_usb_audio,snd_hwdep,snd_timer,snd_pcm,snd_rawmidi,snd_usbmidi_lib,snd_seq_device

The ALSA blacklist cat /etc/modprobe.d/alsa-blacklist.conf contents are:

blacklist snd_bcm2835

I have added following lines to /usr/share/alsa/alsa.conf:

defaults.ctl.card 1
defaults.pcm.card 1

The mixer settings show:

$ amixer -c 0 sget 'Mic',0
Simple mixer control 'Mic',0
  Capabilities: cvolume cvolume-joined cswitch cswitch-joined
  Capture channels: Mono
  Limits: Capture 0 - 4
  Mono: Capture 3 [75%] [4.00dB] [on]

But when I use arecord it gives this error:

$ arecord output.wav
arecord: main:722: audio open error: No such file or directory

$ arecord -r 16000 -f S16_LE output.wav
arecord: main:722: audio open error: No such file or directory

$ arecord -D hw:0,0 -f S16_LE test.wav
Recording WAVE 'test.wav' : Signed 16 bit Little Endian, Rate 8000 Hz, Mono
arecord: set_params:1239: Channels count non available

I can't figure out what is wrong.

4

Resolved this by following commands

$ arecord --device=plughw:0,0 --format S16_LE --rate 44100 -c1 test.wav
$ aplay --device=plughw:0,0 test.wav

This allows recording from mic and playing on speakers

Alternatively, use this process

$ aplay -L
    Discard all samples (playback) or generate zero samples (capture)
sysdefault:CARD=C320
    Plantronics C320, USB Audio
    Default Audio Device

Then choose one of the cards. I chose sysdefault:CARD=C320 and executed these commands

$ arecord -D sysdefault:CARD=C320 test.wav --format S16_LE --rate 44100 -c1 test.wav
$ aplay -D sysdefault:CARD=C320 test.wav
0

It looks to me that you are setting your default card to be at 1,0 when your mic is listed at 0,0. Try adding --device=hw:0,0 to your arecord command.

So your command should be:

sudo arecord --device=he0,0 -r 16000 -f S16_LE output.wav

Note that you do need sudo to use arecord.

  • Getting this error: ALSA lib pcm_hw.c:1667:(_snd_pcm_hw_open) Invalid value for card arecord: main:722: audio open error: No such file or directory – Puneet Ghanshani Mar 14 '16 at 0:38
  • @PunitGanshani oops, there was a typo in my answer, I fixed it. (I forgot a space.) – Patrick Cook Mar 14 '16 at 1:07
  • I did add a space and try at the first go, but it did not work :( – Puneet Ghanshani Mar 14 '16 at 1:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.