0

I just downloaded Raspbian Jessie Lite (2016-02-26) from official website, have written the image on the micro SD card, and tried it on my headless RaspberryPi 2, with only an ethernet cable.

It doesn't boot:

  • the Ethernet LEDs are off

  • the green power LED and the red LED stay constantly on.

  • the power unit is working (when I use my other SD card with another install, it works perfect, and has always worked perfectly in the past since years).

As the computer is headless (I have no HDMI screen to test otherwise, and no USB keyboard, I always used succesfully SSH in the past during years), it's difficult to debug.

What could be the cause?

5
  • Does the ACT led flash in a certain pattern? How did you format your card? What are you using to power your Pi? What model Pi are you using? There are so many things left out of this question. – Patrick Cook Mar 13 '16 at 22:23
  • See my answer to non-booting Pis here: raspberrypi.stackexchange.com/a/41455/33979 – Patrick Cook Mar 13 '16 at 22:27
  • Patrick is right about the solid green meaning the card is not being recognized, i.e., was not created properly or cannot be used with the reader. However, contra the documentation jessie-lite does not have ssh enabled by default, hence the duplicate. – goldilocks Mar 13 '16 at 23:46
  • @goldilocks The problem was the card indeed. Once the card problem was solved, it worked straightforward. SSH was enabled by default, I had nothing to do to enable SSH. Then the linked - duplicate question does not apply to this question, this is misleading because there is no SSH thing to do in Raspbian Jessie Lite (2016-02-26), can you remove the duplicate because it was really something different here? – Basj Mar 14 '16 at 7:50
  • Alright. Since Patrick's answer doesn't actually refer to the "both lights on" (only the 2B does this, as far as I've noticed), I've linked it to a Q&A that does. – goldilocks Mar 14 '16 at 11:43