2

When I click on the Eject menu in the top-right corner, I see this menu: enter image description here

Is this normal? It seems odd to me that the SETTINGS partition shows up here since I don't remember seeing it before I reformatted my SD card, but I haven't been able to find any screenshots of the Eject menu to tell if this is normal.

EDIT: I guess my question is: Could you tell me if you see this on your Pi, or is it just me?

  • Apparently this is normal behavior, because I reformatted my SD card again to test something and I still see this partition in the Eject menu. – tjohnson Mar 16 '16 at 10:21
2

I'd guess it's a feature of LXDE, which is not unique to the pi, and the particular "eject" widget which has noted the card is present/mounted and so offers you the option of unmounting and ejecting it.

Which will not work -- the system on the pi will not allow it. So is it "normal"? I suppose so, presuming the creator of the widget either did not bother or opted not to have it check what is actually possible and what is not. Does it then make much sense in this context? No, but again, LXDE was created a decade ago for use on lightweight PC's, etc.

  • Thanks. Could you tell me if you see this on your Pi? – tjohnson Mar 14 '16 at 14:56
  • 1
    I don't use LXDE; there are a pile of other desktop environment options, although on the pi I'd recommend sticking with LXDE or XFCE or a stand-alone window manager since most other stuff will be a bit heavy. You have to install all that yourself though, and unless this "eject" widget is serious problem I'd just not worry about it. There are much, much worse software bugs to suffer... – goldilocks Mar 14 '16 at 15:02
1

The "SETTINGS" partition in itself is nothing abnormal. It's a part of NOOBS: the boot/setup software that allowed you to boot up and install Raspbian (or some other Linux distribution) the first time you booted up your Pi – before your Pi's microSD card had any OS installed on it. (More on that...)

But from a user experience aspect it's wierd (or distracting) that keeps auto mounting (ending up in the "Eject menu) on every boot up. Probably just wasn't taken into account by the developers.

If you want to tidy up the user experience on your system yourself and get rid of the "SETTINGS" partition in the "Eject" menu, then you can do that by preventing the "SETTINGS" partition from auto mounting on every boot up.

I wouldn't recommend trying to delete or in other ways alter the partition itself, as I don't know what consequences that would have for the system.

How to prevent the "SETTINGS" partition from auto mounting

This is done by editing fstab (read about it here).

First back it up, before you make any changes. In the terminal, write the command:

cp -T /etc/fstab /etc/fstab.backup

Now you can go ahead and edit fstab.

sudo nano /etc/fstab

It should look something like this:

proc            /proc           proc    defaults          0       0
/dev/mmcblk0p6  /boot           vfat    defaults          0       2
/dev/mmcblk0p7  /               ext4    defaults,noatime  0       1
# a swapfile is not a swap partition, no line here
#   use  dphys-swapfile swap[on|off]  for that

Now add this row in the table:

/dev/mmcblk0p5  /               ext4    noauto            0       0
  • /dev/mmcblk0p5 is the "SETTINGS" partition's kernel naming descriptor.
  • / is the value in the <dir>-column (explained in greater detail if you read about fstab).
  • ext4 is the partition's type. noautois the game-changing value that prevents the auto mounting.
  • The zeroes are the values in the <dump> and <pass> -columns (more on that if you read about fstab).

What you end up with should look something like this:

proc            /proc           proc    defaults          0       0
/dev/mmcblk0p5  /               ext4    noauto            0       0
/dev/mmcblk0p6  /boot           vfat    defaults          0       2
/dev/mmcblk0p7  /               ext4    defaults,noatime  0       1
# a swapfile is not a swap partition, no line here
#   use  dphys-swapfile swap[on|off]  for that

Now just save (Ctrl+O) and exit (Ctrl+X) fstab and you're good to go. Next time you boot up your system, the "SETTINGS" partition won't auto mount.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.