0

I've bought my new Raspberry Pi 3, plugged it in, took my Raspberry Pi 2 SD Card with Raspbian installed on it.

Turned it on, everything is working great and faster than ever - but!

No wireless adapters are shown in the wpa-gui app\ifconfig, nor I can't connect to any network (kind of because of that).

I did able to get wireless from an external adapter and update&upgrade the system + I did rpi-update.

Nothing helped, I can't get the internal wireless to work. Any ideas?

I'm using the RSElectronics PI, + Raspbian version of 4.1.18-v7+

Am I missing some drivers? How can I solve it?

  • Did you do a sudo apt-get update sudo apt-get dist-upgrade which should install needed drivers. You SHOULD NOT run rpi-update which is for beta testers only. If you already have working WiFi on the same network nothing more is needed. – Milliways Mar 15 '16 at 10:32
  • So I did the dist-upgrade and now the bar has moved to the top (moved it back down ;P) . even though I can see it's the same version in uname and I do have some UI changes, no Wifi still. I have an icon of 2 computers with an X. the wpa_supplicant.conf is configured well and ifconfig still doesn't show any wlan adapters – Roi Katz Mar 15 '16 at 12:40
2

The current version doesnt contain the drivers. I am sure an update will come along soon where they are included! (please note this applies to both NOOBS itself 1.8.0 and Raspian)

A corroborating article

UPDATE: Officially fixed

  • So how come that most people can use the internal Wifi without any issues? – Roi Katz Mar 15 '16 at 15:23
  • added a link that corroborates. Although true right now, I doubt it will be excluded for long – Emanuele Ciurleo Mar 15 '16 at 15:29
  • 1
    Hmm, so If I start from scratch, and reload the image to the SD card I will have the drivers, and if I'm upgrading I'l have to wait for the drivers? Did I understood correctly? – Roi Katz Mar 15 '16 at 15:33
  • Mine worked perfectly. I upgraded my Pi2 image (according to the recommended instructions) and inserted the card into the Pi3 and it worked. I did need to install bluetooth drivers (as explained in MagPi). – Milliways Mar 15 '16 at 23:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.