0

The WiFi country code keeps resetting to Andorra. My code is ZA. When it does connect occasionally, the net works fine.

I have tried using the pull down preferences menu and the terminal to set it but it keeps jumping back after a while.

  • Hello and welcome. Which Pi? Which OS (version)? – Ghanima Mar 16 '16 at 9:47
1

Looking at WiFi country code resets, it seems that the Wi-Fi Country Code menu to which you refer, by default, the version of Jessie that you have, displays Andorra, even if the actual country code is set to something different, which indeed sounds like a bug.

However, if you look at the actual config file, what country code is listed?

sudo cat /etc/wpa_supplicant/wpa_supplicant.conf

If that still says Andorra, then you may be better off setting the correct code in this file manually and ignoring the GUI menu, for the time being.

I would also ensure that you have the latest update, as the issue that you have found may already be fixed:

apt-get update
apt-get dist-upgrade
0

There appears to be a bug in the OS Jessey OS 8 Raspbian. It will not allow users to remove the AD Wi-Fi Country Code. As a result the Wi-Fi is unable to properly connect to your local network. Unless you live in AD Andora :-)

If you have a password network, it rejects your password. All attempts to rewrite the code are rejected with permission denied. You will have to use the Ethernet cable until this disaster is solved with an update.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.