1

I have a problem with tor (this version and also 0.2.7.*). After compilation, with and without installation afterwards, I can'treach port 9050. I would like to see with arm what's going on but it doesn`t work.

blabla@Raspb:~$ sudo -u debian-tor arm
Connection refused. Is the ControlPort enabled?

When I do this it won`t work either.

blabla@Raspb:~$ sudo -u debian-tor arm -i 127.0.0.1:9050
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/TorCtl/TorCtl.py", line 645, in _loop
    isEvent, reply = self._read_reply()
  File "/usr/lib/python2.7/dist-packages/TorCtl/TorCtl.py", line 820, in _read_reply
    raise ProtocolError("Badly formatted reply line: unknown type %r"%tp)
ProtocolError: Badly formatted reply line: unknown type 'P'

But tor binds the port

blabla@Raspb:~$ sudo netstat -tulpan | grep "9050"
[sudo] password for torpi: 
tcp        0      0 127.0.0.1:9050          0.0.0.0:*               LISTEN      17247/tor

I`ve search many things but still got no solution. My torrc works fine. I have to say on the beginning tor can't bind port 80 and 443. After I did this it worked.

sudo setcap CAP_NET_BIND_SERVICE=+eip /usr/local/bin/tor

Is their relation compared to port 9050? When I install tor from the repositories all worked fine. Hope you can help me.

Thanx!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.