0

This question already has an answer here:

I have scoured the internet looking for drivers for the WNDA3100 wifi dongle. I am using Raspbian Jessie. My RPi is the 2 B+ model. I cannot find the drivers anywhere. Wherever I look, I am told to use Windows to install the drivers, and move them to the Raspbian.

I will be happy to provide more information when asked.

marked as duplicate by Jacobm001, joan, Steve Robillard Apr 1 '16 at 5:02

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1

Wherever I look, I am told to use Windows to install the drivers, and move them to the Raspbian.

This is nonsense, and I'm not sure why anyone would tell you to do this. Drivers must be written for their respective operating systems.

According to Netgear's website, there is no Linux support for that particular Wifi Dongle. If it doesn't work by simply plugging it in, you'll need to purchase a different model.

  • I have found a website with the link to the driver, but I can not find it again despite my hours of searching. – Tyler Richardson Mar 16 '16 at 21:47
  • 1
    @TylerRichardson: For an ARM linux driver? I find that doubtful... – Jacobm001 Mar 16 '16 at 21:52
1

As Jacobm01 says in his answer, there is not official driver supplied for that particular Wi-Fi device, for the Pi, when the Pi is running Raspbian.

The WNDA3100 might work, if you were to install Windows 10 IoT - not that I am recommending that. Having said that, as Jacobm01 points out in his comment, the Windows 10 IoT driver would still require to have been compiled for ARM, en lieu of x86, so, until those drivers become available, the WNDA3100 would still not work.

Take a look at the thread, No WiFi Adapters found - Netgear WNDA3100, in particular:

See the warning here for that device (This applies to version 2):

http://elinux.org/RPi_VerifiedPeripherals

You will have to search around for a driver, as it does not exist with the Linux operating system as shipped.

As that answer suggests, you are best off using the WNDA3100 on some other device, and instead looking for a peripheral that is verified to work with the Pi, by checking the list at RPi VerifiedPeripherals.

See also: How do I install my NETGEAR N600 Dual Band USB Adapter WNDA3100

Update

However, if you use Ubuntu, instead of Raspbian, then there is a chance that you could use ndiswrapper, see the answer to this question: WNDA3100 wireless adapter has stopped working under Ubuntu 12.04. Also, as Ubuntu and Raspbian share the same Debian base, this method could still be applicable in your case. I have not tried this though. Maybe someone else could elaborate?

Not the answer you're looking for? Browse other questions tagged or ask your own question.