1

I backed up my Pi 8GB SD card using Win32DiskImager. I then wrote that image to another (exact same size/brand) 8GB SD card, again using Win32DiskImager.

Now when I tried to boot the Pi using that new SD card, I got a kernel panic with this error:

Kernel panic-not syncing: VFS: unable to mount root fs on unknown-block(179,6)

I found this page on the site: Kernel panic-not syncing: VFS: unable to mount root fs on unknown- block(179,6) running Raspbian on top of NOOBS

I followed the process there and fsck.ext4 sat there for 10-15 minutes fixing stuff.

Once that was done, I rebooted and am now faced with this error:

Kernel panic - not syncing: No init found.  Try passing init= option to kernel. See Linux Documentation/init.txt for guidance.

I tinkered with the parameters in cmdline.txt as described here, but no luck: Error on Boot. 'No working init found.'

I can basically get this to bounce between the first and second panic errors (VFS error or no init error) by changing the cmdline.txt file parameters.

I have a second Pi, I am able to mount the SD card from the non-functional one and I can see all the data files etc, so I'm at a loss as to what the problem could be. I am by no means a linux jockey so I imagine there's some low-level config file somewhere that's messed up, though how that happened when this was a direct copy of the original SD card image I have no idea.

Anyway, I would ideally like to recover this, as setting up the environment etc., was time-consuming, and I would prefer not to have to do it again. But at least the files (scripts & such) can be recovered.

Let me know your thoughts/suggestions.

  • As a sanity check, have you tried re-writing the image to the card? It sounds like the boot partition is messed up. The boot partition is separate to the one that stores your files. – yogsodoth Mar 17 '16 at 17:38
  • Yes, I did try rewriting it and unfortunately there's no change. In fact I also wrote it to a different SD card with the same result... – tstevens Mar 17 '16 at 20:50
  • Try to boot the second pi from that card, it might be a bad card.. – unixb0y Apr 19 '16 at 22:16
-1

I followed the steps from the below link when I upgraded my Raspbian after quite sometime now.

https://www.raspberrypi.org/documentation/installation/noobs.md

Things that you should note

  1. Format your sd card and make sure it shows up the complete space. In your case it should be around 7-8 Gb.

  2. Download the noobs from the link and then unzip the contents.

  3. Copy paste the unzipped files into your sd card.

  4. Boot your Raspberry Pi after connecting the device with a monitor (HDMI). Its needed only for first time when you do you the installation and basic configuration.

That's it. Let me know if you are stuck in the above steps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.