I've noticed this a few times now. After I reboot the pi from the shutdown menu in Raspbian it reboots and doesn't get past the loading screen with a flashing dash in the top right corner, rendering it virtually useless. Not sure if SSH was working up to that point, kind of regret not checking, if I had I could of checked out the logs.

It's kind of annoying because I have to re-flash the image onto the sd card again every time it happens (happened about 5-6 times now). The only causes I can think of are a damaged SD, or perhaps its not fast enough, I've ruled out insufficient power draw, it has a good adapter.

  • you can't rule out power issues without measuring the voltage at the board. Just because it says 5 volts and 2 Amps does not mean that is what the board is seeing for a myriad of reasons. This or the SD card is the likely cause of the issue. I would get a multi meter and measure the current then get a new SD Card. Mar 17, 2016 at 5:05
  • I was really hoping that wasn't the case. I bought it from one of those bundles on Amazon for almost $100, you'd think they would put in a working ps.
    – ipconfig
    Mar 17, 2016 at 5:08
  • Like I said get a meter and test it. Mar 17, 2016 at 5:09
  • What happens if you choose to shut down, then (after waiting for the Activity light to stop flashing) cycle power to the Pi? Will it boot successfully from a power-off state? Mar 17, 2016 at 15:21

2 Answers 2


This may be caused by the limited space in the partition of the SD card. I fixed it as follows:

  1. First, I reinstalled the Raspbian image.
  2. Then, I expanded the system space from the desktop:

Menu > Preferences > Raspberry Pi Configuration > Filesystem Expand button.

After this I could restart without problems.


More than likely could be an issue with the firmware/version of Raspbian you have. Try running these through Terminal:

sudo apt-get update
sudo apt-get upgrade

In your case, since you can't reboot, just choose to shutdown your Pi.

Also, have you tried doing startx? If you have the option to login, and it shows a Terminal screen by itself, all across your screen with no GUI, then startx isn't pre-enabled.


If you aren't able to get to the shell, I would suggest you re-install NOOBS as well as all of Raspbian, and if that doesn't fix the boot-up issue (which I would be extremely surprised if it didn't), I would try to talk to somebody at the Pi Foundation.

  • 1
    Do not unplug your Pi without a shutdown! That will very likely corrupt your filesystem! Mar 17, 2016 at 15:16
  • Good point, it's not too likely but I shouldn't be mentioning it anyway. Thanks. @Lotharyx
    – Dylan
    Mar 17, 2016 at 15:18
  • Also I don't think he's getting as far as an interactive shell where he could try startx. Mar 17, 2016 at 15:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.