0

I have recently been trying to use the Pi 3 to make a automatic seedbed with sickrage and transmission by following guides on htpcguides.com. Right now, my Pi3 is unable to resolve host addresses to sites like google.com.

I have tried adding

dns-nameserver 8.8.8.8 8.8.4.4 127.0.0.1

to my /etc/network/interfaces file but it does not seem to work

I have also tried editing /etc/resolv.conf but I understand from googling that it regenerates upon reboot.

Any help/advice is much appreciated. Thanks!

2
  • Could you try adding an 's' to dns-nameserver? 'dns-nameservers 8.8.8.8 8.8.4.4'
    – goobering
    Mar 17, 2016 at 15:59
  • can you pls post the whole content of /etc/network/interfaces because i also have the same problem Apr 14, 2017 at 5:26

1 Answer 1

0

In /etc/network/interfaces the configuration option for dns servers is dns-nameservers with an s, as opposed to dns-nameserver singular. Correcting the typo solved the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.