1

I have an LCD-PI32 3.2 provided from hwlevel.com. This was working great with their kernel modules provided for 3, however after I recently upgraded my Rapsberry Pi to kernel 4 it is no longer working for me.

I read somewhere that kernel 4 completely remapped the way modules are seen by the kernel.

I have tried to use the available modules that are apparently now built in, but these do not work for me since I am ignorant on what I am doing here.

The first problems is the modules I had are not being loaded. spi-bcm2708 ssd1289 and ads7846

# lsmod
Module                  Size  Used by
fbtft_device           35066  0
fb_ssd1289              5269  0
fbtft                  34216  2 fb_ssd1289,fbtft_device
syscopyarea             3113  1 fbtft
sysfillrect             3592  1 fbtft
sysimgblt               2286  1 fbtft
fb_sys_fops             1573  1 fbtft
snd_bcm2835            22317  0
snd_pcm                92581  1 snd_bcm2835
snd_seq                61957  0
snd_seq_device          5130  1 snd_seq
snd_timer              23454  2 snd_pcm,snd_seq
snd                    68161  5 snd_bcm2835,snd_timer,snd_pcm,snd_seq,snd_seq_device
spi_bcm2835             7948  0
bcm2835_gpiomem         3703  0
uio_pdrv_genirq         3690  0
uio                    10002  1 uio_pdrv_genirq

Loading these manually does not help and configuring these to load at boot time is still a no go.

I try using a custom setting based off the schematic layout sheet provided.

#modprobe fbtft_device custom name=ssd1289 speed=32000000 buswidth=8 gpios=reset:8,led:30,dc:5

[1937509.812706] fbtft: module is from the staging directory, the quality is unknown, you have been warned.
[1937509.822692] fb_ssd1289: module is from the staging directory, the quality is unknown, you have been warned.
[1937532.696205] fbtft_device: module is from the staging directory, the quality is unknown, you have been warned.
[1937532.700286] fbtft_device:  SPI devices registered:
[1937532.700335] fbtft_device:      spidev spi0.0 500kHz 8 bits mode=0x00
[1937532.700355] fbtft_device:      spidev spi0.1 500kHz 8 bits mode=0x00
[1937532.700371] fbtft_device:  'fb' Platform devices registered:
[1937532.700414] fbtft_device:      soc:fb id=-1 pdata? no
[1937532.700502] fbtft_device: Deleting spi0.0
[1937532.703874] spi spi0.0: setting up native-CS0 as GPIO 8
[1937532.704071] fbtft_device:  GPIOS used by 'ssd1289':
[1937532.704093] fbtft_device:    'reset' = GPIO8
[1937532.704110] fbtft_device:    'led' = GPIO30
[1937532.704123] fbtft_device:    'dc' = GPIO5
[1937532.704134] fbtft_device:  SPI devices registered:
[1937532.704150] fbtft_device:      spidev spi0.1 500kHz 8 bits mode=0x00
[1937532.704165] fbtft_device:      ssd1289 spi0.0 32000kHz 8 bits mode=0x00

My screen will flash for a brief moment and then goes black again. And then after a few moments the Pi becomes frozen and I have to do a hard reset on it.

I'm really lost at this point and any information would be helpful.

  • I think you are having problems because you are using a module/patch provided by the LCD supplier that is built against a particular 3.x kernel but having upgraded your system to a different 4.x one (though you could still get the same issue even with a different 3.x one) you will need that module to be recompiled for the different kernel. – SlySven Mar 18 '16 at 17:47
0

I think you must avoid changing your kernel image - the manufacturer has provided newer SD card images here and at the time of writing they offer:

  • 2015-09-24-raspbian-jessie image with 4.1.10 kernel
  • 2015-05-05-raspbian-wheezy image with 4.0.7 kernel

However you are tied to reinstalling one of those new SD images if you want to use the screen, unless they provide a means to patch a range of kernels.

Given that the supplier is at least based in the EU area (Slovenia) and not in the Far East it might be worth trying to get in touch with them and asking for support (there is a forum on their web-site but the last posts there date from 2014 so may not be too helpful) - or at least the patches needed to use with the kernel you currently want to use...

  • Thank you for your response. I was afraid that I would end up having to do something like that. I'm not really sure it will be worth it at this point and will probably just opt to buy an model from a manufacture that has support built into the standard Raspbian kernel. – Ellicia Mar 19 '16 at 1:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.